Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Install Errors


Guest

Recommended Posts

Hi All,

 

OK, got to the last part of the install and i got this error

 

New Install



Step 2: osCommerce Configuration





Warning: fopen("/home/sites/site35/web/directory/includes/configure.php","w") - Permission denied in /home/sites/site35/web/catalog/install/templates/pages/install_5.php on line 164



Warning: Supplied argument is not a valid File-Handle resource in /home/sites/site35/web/catalog/install/templates/pages/install_5.php on line 165



Warning: Supplied argument is not a valid File-Handle resource in /home/sites/site35/web/catalog/install/templates/pages/install_5.php on line 166



The configuration was successful!

 

I can enter the store, but if i try and enter admin i get this error and nothing else on the page.

 

Fatal error: Failed opening required 'includes/application_top.php' (include_path='') in /home/sites/site35/web/directory/index.php on line 13

 

Any ideas please!

Link to comment
Share on other sites

Was just doing this, and 777 got the install working, but had to change to 704 to get rid of the warnings in the header.

 

All seems to be OK now,

 

THANKS

Link to comment
Share on other sites

I got the same errors. I chmod'd the configuration.php to 777 in both admin and catalog directories, chmod'd the includes folders as mentioned in other posts on this topic. Alas, it was to no avail.

 

Then I read a post from a guy that said you had to make sure the paths to your admin folder were correct. Oscommerce looks for it in '/catalog/catalog/admin/' and I had mine in '/catalog/admin/'. Thinking about it now, when I tried to reinstall and redirect the config to '/catalog/admin/ ' I mistakenly directed it to '/catalog/admin/admin/' which was one level too deep. (I can see that easy mistake now but after spending an hour trying to guess the database server name (hostname:www.mysite.com) its easy to make a typing mistake.)

 

Anyway...I started over and uploaded the package with the admin folder in the catalog folder. I chmod'd the two configuration php's and now it all works swell.

 

Thanks for all the help and I hope my post helps another.

Link to comment
Share on other sites

sorry, and the important part is...then I just left all the settings in the default postion and had no need to worry about typos.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...