Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Categories/Products


Guest

Recommended Posts

Hi,

 

Need some help with the product details section in Admin.

 

I have added a new product the database and I started to add the information in the Product Description box, by complete accident I found out you can use HTML code to format the text so I created a new description using notepad and pasted it straight in.

 

The product description appears as intended in the catalog section however there is a red error message at the bottom of the page with the text "Error!

 

Unable to determine connection method on a link!

 

Known methods: NONSSL SSL".

 

I have checked my html code and there is no reference to an external link so what is going on?

 

The only mods I have added to the page are to remove international stuff (not needed as I will be trading in the UK) and I added the Big Images 1.24 mod and the popup window mod to make it close when someone clicks on the window.

 

I have never seen this error before and I am pretty sure after I modded the site everything still worked.

 

Anyone know why this message appears, also strangely the notifications box that appears in the right column has just the title and nothing else, no box underneath the heading.

 

Have I messed something up?

 

 

Thanks in advance,

 

Taz

 

B.T.W - I tried to remove the HTML code and just use plain old text in the product description but this did not resolve the problem. I am running OSCommerce 2.2 MS1 on a Windows XP development PC which has the latest version of Apache installed, PHP 4.3.2 and MySQL; I know this setup works as I have tested various flavours of OSCommerce without a hitch.

Link to comment
Share on other sites

Hey thanks for the reply.

 

Oh no, do I have to delete the whole category or just the product in question?

 

Damn, that means I've got to re-enter all of the products..

 

I will try a backup for comparison and backtrack my way to the problem.

 

 

Thanks,

 

Taz

Link to comment
Share on other sites

wait, quick oh, oh@

Sorry about that...there is a copy function if i remember correctly, let me look....Yep its cald Move. Excuse me but it's late, try the move thingy it might save you time :wow:

Link to comment
Share on other sites

Hi,

 

I tried what you suggested and the problem still persisted and then I remembered I had added another box in the column_right.php file.

 

This box was linked to a hyperlink I had added on the mainpage of OSCommerce so users would get a welcome message and a random link pulled from the database.

 

I should have read the error message properly, the box was trying to pull the info in from the mainpage but couldn't because I was making a direct reference to a filename.

 

I resolved the problem by creating a define in application_top.php:

 

define('HYPERLINK', 'randomlink.php');

 

In my code I was using:

 

tep_href_link(HYPERLINK, ')

 

When it should have said:

 

tep_href_link(HYPERLINK, '', 'NONSSL')

 

The

'NOSSL'

or

'SSL'

needs to be added so OSCommerce can access external links and references.

 

All sorted now!

 

Thanks for the help, I haven't done too badly since I don't know the first thing about PHP but I am learning fast even if I keep falling off the vertical learning curve :D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...