Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FYI - It seems that UPS is down.


mattcald

Recommended Posts

Getting this error on several carts.

 

Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /catalog/includes/classes/http_client.php on line 330

 

Warning: fsockopen() [function.fsockopen]: unable to connect to www.ups.com:80 in /catalog/includes/classes/http_client.php on line 330

** God Bless **

---------------------

Link to comment
Share on other sites

Not for me. My customers are getting quotes with regularty.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

  • 1 month later...

I'm getting this error:

 

United Parcel Service (XML)

Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway :

 

 

I just activated the mod, put in my access key, login, password and all that stuff.

 

It's not the same error as what you were getting, so I"m wondering if it's UPS or an error on my end :(

Link to comment
Share on other sites

Gisele, I am getting same error. One thing I did learn is that a Developer's Key is not an Access Key from UPS. So, I got the right Access Key and tried again. I am still getting the sme error. I downloaded the developer's tools kit and it does say to use SSL. I am not doing that on my development server. But it is 3 a.m. and I need to sleep. Maybe you will have an answer when I wake up. :D

Link to comment
Share on other sites

Thank you, Torin! Your UPS XML contribution is working perfectly.

 

Errors I initially was getting were because of silly things.

1) I tried to use my Developer's access code instead of real access code

2) I tried to do this on my development server that did not have SSL and UPS requires SSL.

3) I put the country code in as USA instead of US.

 

I'm not sure I need this now that errors are fixed, but I wound up adding this line to the .htaccess file on my web host to avoid error messages.

 

php_flag allow_call_time_pass_reference on

 

Thanks again for all your hard work on this great contribution.

Link to comment
Share on other sites

which .htaccess, the one under catalog?

 

I did confirm that I am using the Access Key, userid and password.

We do have SSL, but when you checkout, the first screen where the UPS error appears, it's not through SSL, the site goes to SSL only at the payment screen which is the next one.

 

I put your code in the .htaccess under catalog, restarted apache and I'm still getting the error.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...