Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Unable to Properly Add or Edit Categories or Products


cpachmayr

Recommended Posts

For some reason I am unable to add categories or products ...

 

When adding a new category, a new line does appear - however the name and/or image won't update in the database... the same with a product.

 

In fact, if I edit an existing category or product - its image, description, price, (all data) etc. disappears - but obviously the row is still there in the database because I can continue to click to edit - it just won't update.

 

I have checked all of my permissions - in fact - I've basically opened up the whole world to make changes to the database and tables.

 

I know of one other person having this problem (posted in this forum) but I think the topic may have been misleading - and nobody as replied yet to that person (except for my joining in agreement).

 

Any help would be greatly appreciated! Thanks in advance! :D

Link to comment
Share on other sites

In fact - I'm realizing that it seem odd that I can update the tables with all of the configuration information (store name, etc.) but I can't add new products or categories. hmm.... very frustrating! :?

Link to comment
Share on other sites

I became very frustrated with the same issue, thinking that some of their code was wrong.

 

I fixed my problem by actually putting the folders right off the root. I have a catalog and an admin folder now off the root instead of deep down in my file structure.

 

Worked for me. :D

Link to comment
Share on other sites

Do you mean the "Root" of the public HTML directory, or the Root of the file system?

 

Currently, from the "root" of the publich HTML directory (or even the file system in this case) it doesn't seem too far down:

 

My structure is as such:

 

/var/www/catalog/admin

 

I also tried /var/www/catalog and /var/www/admin (admin outside of catalog)

 

I can't really move anything above the 'www' directory or users won't be able to get to /catalog/default.php

 

I actually went to a different host provider - installed everything the EXACT same way and it worked perfectly first time. The site that isn't working is hosted on a Virtual Private Server - and I'm thinking it may be an issue with how VPS handles things ... but I'm testing it on a normal shared account with the host provider to see if it is something else (like mySQL or PHP install problem on their end).

 

I will post what I find - cause I know I can't be the only one who's having this problem.

Link to comment
Share on other sites

Does anyone know how I should install osCommerce if the host provider has separate html folders for secure and non-secure data?

 

My provider has domain-www and domain-secure

 

Should I just install the whole package under domain-secure?

Link to comment
Share on other sites

Open mouth - insert foot

 

Sorry for last post -- should have checked first...

 

Everything copies over to the secure directory automatically...

 

So never mind .... as you were!

 

:oops:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...