Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR: register_globals is disabled in php.ini, please


awarlock

Recommended Posts

I installed Microsoft IIS 5.1 on Windows XP

I installed PHP 4.3.2

 

I go to localhost/catalog/catalog/install.php

and i have this error:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

 

PLEASE HELP :

total newbie. pls be kind.

Link to comment
Share on other sites

You need to edit your "c:windowsphp.ini" file.

 

Find the 'register_globals' sections and change it from

register_globals = off

to

register_globals = on

 

HTH,

Tony

"The price of success is perseverance. The price of failure comes much cheaper."

Link to comment
Share on other sites

  • 3 years later...
You need to edit your "c:windowsphp.ini" file.

Find the 'register_globals' sections and change it from

register_globals = off

to

register_globals = on

HTH,

Tony

 

I have the same error and I modified the change as decribed above. it did not solve my problem.

 

My php.ini file is in public_html directory which is also the WWW directory.

 

My installation folder is /public_html/sub_domain/catalog/

 

My sub_domain is different domain name than the primary domain.

 

Please help

 

Thank you

Link to comment
Share on other sites

  • 4 weeks later...

Hi,

 

New to adding a shopping cart and I'm having the same problem.

 

I get:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I see by the posts that the register_globals needs to be turned on but I can't find that file anywhere.

Can you give me some idea of where it would be located.

 

Thanks,

Ceil

Link to comment
Share on other sites

OK I downloaded the update and got to the OSCommerce database login page. I created a SQL database with my host (InMotion), wrote down the user name, database name, password and IP address. When I enter that info on the database login page it says:

 

There was a problem connecting to the database server. The following error had occured:

 

Access denied for user 'dejewe5_admin'@'gs19.inmotionhosting.com' (using password: YES)

 

Please verify the connection parameters and try again.

 

 

Where do I find the user name and password?

 

Thanks,

Ceil

Link to comment
Share on other sites

I have the same error message:

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

No idea how, I've had OSC installed and working fine for months with no problems. Went to log in today and get this error. I've looked through all my files but honestly don't no which file I need to change and where it's located. I don't want to make things worse by making changes in the wrong place.

 

Please can someone advise me

Link to comment
Share on other sites

I have the same error message:

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

No idea how, I've had OSC installed and working fine for months with no problems. Went to log in today and get this error. I've looked through all my files but honestly don't no which file I need to change and where it's located. I don't want to make things worse by making changes in the wrong place.

 

Please can someone advise me

 

 

I've read through so many posts on this my eyes are bleary but from what I can gather I can't see where the problem lies, I eventually located what I think is the correct .htaccess file

 

#<IfModule mod_php4.c>
#php_value session.use_trans_sid 0
php_value register_globals 1
#</IfModule>

 

which appears to be correct? so I can't see where the issue lies.

 

Can anyone give any clues to what the problem may be?

Link to comment
Share on other sites

Ok, I'm still getting the errors like others, I've edited the .htaccess file and tried it several times, so I found the thread in Contributions and downloaded the patch file. Now my question is: how do I install the patches? Do I just copy the new files in or do I run the install.php in catalog\install\includes or? :(

Link to comment
Share on other sites

Ok, I'm still getting the errors like others, I've edited the .htaccess file and tried it several times, so I found the thread in Contributions and downloaded the patch file. Now my question is: how do I install the patches? Do I just copy the new files in or do I run the install.php in catalog\install\includes or? :(

 

 

Never mind, looks like I got it working or at least I'm getting in and to the admin panel. Now for the "fun" of learning and setting it up! Only have a couple hundred items and 5-7 sizes to go!!

 

Deen

Link to comment
Share on other sites

I've also got the same error message?

 

"Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory."

 

My files are installed in public_html directory on Linux Operating system operation PHP version 5.2.1

 

I don't have a calalogue directory, or a php.ini file. In the osCommerce main directory I have altered the htaccess file as follows by removing the # symbol.

 

<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

 

I still get the same error message in both the root directory and the Admin directory.

 

Would appreciate help to fix this?

 

thanks

Link to comment
Share on other sites

try one of these.

1. Modify php.ini to turn global_registers = on

2. Add .htaccess files to htddocs, catalog, admin and install folders with the line php_value register_globals 1

3. Add php.ini with global_registers=on to htddocs, catalog, admin and install folders.

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

try one of these.

1. Modify php.ini to turn global_registers = on

2. Add .htaccess files to htddocs, catalog, admin and install folders with the line php_value register_globals 1

3. Add php.ini with global_registers=on to htddocs, catalog, admin and install folders.

 

Satish

 

 

I don't have a php.ini file or htddocs & catalog dirs.

I have a htaccess file in both the root and admin dirs.

I have enabled the following function in both:

 

<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

 

I have a pub, includes, images, download and admin dirs off the root dir.

 

The pub, includes, download and admin dirs all have htaccess files. Only the Admin and root files have the php_value register_globals 1 function.

 

So I am still lost and unable to run the program.

 

cheers

Link to comment
Share on other sites

Well I tried every possible solution I could find on here to rectify this problem, nothing worked. Eventually contacted my server to explain the problem and they came back with reply that they had enabled register_globals and when i checked, my site was up again. Could access main page and admin but got error message when trying to access any product details.

 

I'm no wiser to what happened and I know that I hadn't made any changes that would have caused this problem so can only assume that the problem was out of my control.

 

I'm now in the process of making necessary changes to put my site back to how it was as the only way I found to rectify the 2nd problem was to re-install my index file. Unfortunately I had made changes and added mods and not backed up all the new changes so now have a lot of work to sort that out but at least I'm getting there :rolleyes:

Link to comment
Share on other sites

Hello, i had this same problem.....

 

you need to create a file (open notepad) and write,

 

register_globals = 1

 

Save the file as

 

php.ini

 

and upload it to the root folder of your site where your stylesheet.css, index.php etc are...

 

PROBLEM SOLVED! (HOPEFULLY)

 

Regards,

Will.

Link to comment
Share on other sites

i have the same problem

 

i have tried everything in these posts but still get same problem with saying that :

 

"Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory."

 

have .htaccess files in all folders that there shoul be

 

it was working untill i added the multi-store

 

any ideas

Link to comment
Share on other sites

Hello, i had this same problem.....

 

you need to create a file (open notepad) and write,

 

register_globals = 1

 

Save the file as

 

php.ini

 

and upload it to the root folder of your site where your stylesheet.css, index.php etc are...

 

PROBLEM SOLVED! (HOPEFULLY)

 

Regards,

Will.

 

This helped me, thanks

Link to comment
Share on other sites

ok, well i just seen whjat was in my reply, saying it helped me, but it didn't still not working.

 

i have added php.ini

 

i have checked all htaccess files

 

i have looked and checked and im not sure what else to look at

 

but i still get the error msg

 

check here at oz-markets

Link to comment
Share on other sites

just a quick update

 

would it make a difference that i install in root not in catalog directory

 

i installed and it was working fine - i then installed multi-store

 

this is where im wondering if there is a problem not being in cataloge

 

?????????

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...