Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installation problems


Guest

Recommended Posts

I'm trying to install oscommerce for the first time but keep running into an annoying error.

 

I'm following the install instructions from http://wiki.oscommerce.com/helpInstallNew this time. I've tried a several install instructions, some using different directory structures, some with different permissions.

 

The problem I'm getting is when I get to the place in the install where you need to run the install.php I always get slammed against an Internal Server 500 error.

 

yourserver/catalog/install/install.php

 

This seems like it should be a very common error, however I've not seen any documentation on how/where to fix it.

 

Any help would be greatly appreciated.

 

Thank you

Link to comment
Share on other sites

You've upload the catalog and the admin ( myself i put admin in my catalog folder) you chmod both configure.php and your images folder to 777?

Link to comment
Share on other sites

yup :/

 

 

and all I keep seeing is:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

Link to comment
Share on other sites

you've got your answer right there .... a server error so contact your provider and explain problem

 

The_Bear

Link to comment
Share on other sites

Just in case this problem pops up in the future here's the answer to it. Might be worth while to stick it in a troubleshooting FAQ.....but that's just my opinion :wink:

 

 

 

The problems has been fixed by adding the php path in the files that require executions.

 

for example:

 

> #!/usr/local/php/bin/php

> ini_set("register_globals",1) ;

 

 

The "ini_set("register_globals",1) ;" is required since

newer versions of PHP consider that the register_globals set

to on is insecure.

 

note: For PHP to work, "#!/usr/local/php/bin/php" must be included

in the first line for those that are being directly executed (not necessary for the include/require ones). e.g. "require('templates/main_page.php');"

Link to comment
Share on other sites

To get the install working "install.php" needs to be modified.

 

Other than that I'm still working on it. Trying to figure out which files need to be modified with the code is getting a little messy, and I've had to reinstall the entire thing a few times. I've gotten the catalog to work, but links from that page are all pulling up 500 error's. The admin section I can get to display, but with to many page error's to consider near working.

 

I may just scrap trying to get it working on this server and find a new host. It's to bad there isn't one spot to define these settings, and that it would work for the entire script.

 

:? will keep you posted

Link to comment
Share on other sites

I'm not sure exactly what is happening on your end, but I discovered something that may help.

 

In the wiki docs it - where it tells you "what needs to be changed in application_top ..." - the information is correct, but the files to change is wrong (probably refers to an earlier version). The files to modify are "configure.php" in Both catalog and admin. Refer to that wiki doc (sorry I don't have the url handy - I'm doing some of this from home and some from a work location) and if you have everything correct you'll see a difference.

 

If you have image problems look at the path to images/icons and a one or two others in the configure.php file.

 

Hope this helps.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...