Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Silly syntax error


valley

Recommended Posts

I have setup an exact copy of the ccatalog, admin

and the database (my ISP allows THREE) on the same server .

 

I have Installed everything in to a new directory

catalog_dev and just changed "catalog" to "catalog_dev"

in the configure files in both catalog/includes and admin/includes.

 

My New store loads normally and evrything works fine

However my Admin page comes with this strange error message.

 

 

Quote:

Fatal error: Failed opening required 'includes/application_top.php' (include_path='./') in /home/affili43/affili43-www/catalog_dev/admin/index.php on line 13

 

 

 

The two configure files have the following settings

 

ORIGINAL :

 

Code:

define('DIR_FS_DOCUMENT_ROOT', '/home/affili43/affili43-www'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/affili43/affili43-www/catalog/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_FS_CATALOG', '/home/affili43/affili43-www/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

 

 

 

The NEW ONE

 

Code:

define('DIR_FS_DOCUMENT_ROOT', '/home/affili43/affili43-www'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/catalog_dev/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/affili43/affili43-www/catalog_dev/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/catalog_dev/'); // absolute path required

define('DIR_FS_CATALOG', '/home/affili43/affili43-www/catalog_dev/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

 

 

I have tried to changethe path of Includes to

without solving the problem

 

Code:

define('DIR_WS_INCLUDES', '/home/affili43/affili43-www/catalog_dev/admin/includes/');

 

 

Can someone think of a reason ?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...