Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problems


1800contacts

Recommended Posts

After struglling with many problems of MS1, I decided to go with 05-18 snapshot. I deleted the old folders (made a backup of course) and installed the fresh, new snapshot 0518. After I uploaded all the files, I got the 'unable to connect to databse' message. Where is the setting i should edit, i.e. database connection string, in order to make it work. I tried catalog/includes/configure.php and

admin/includes/configure.php but didn't have much luck. Anywhere else i need to change?

If everything else works fine, where do i need to change in order to restore back my old store setting? Is it just stylesheet, default, header, footer? ANything else?

 

ALso, in the 5-18 snapshot, what is the purpose of the following folders?

  • CVS

catalog/extras

tep-docs ( do i need to install this as well?)

 

Thanks again.

Richard da bomb

Link to comment
Share on other sites

If you defined your database before installing osCommerce and then give it the proper locations during the install script, you should not have any problems. Look at:

 

http://wiki.oscommerce.com/helpDocuments

 

for assistance with the proper order of everything for installation. It also covers the folders you referenced. The tep_docs don't have to be uploaded. You don't need the extras folder either, for normal shop operation. It just has some extra items if you need them. As an example, it has code to do an SQL query of two database layouts to determine the difference between them. Could be useful if you have an existing older shop and want to use newer version of osC.

 

HankFrid

If I build it...they will come.

If I don't try to build it.....I will never know!

Link to comment
Share on other sites

I haven't played with this snapshot yet myself but here's where I'd start my troubelshooting:

 

configure.php

 

- Make sure that you have specified the correct DB Name, User, and Pass

- If that still doesn't have it, make sure that your file structure is correct. You might be calling to the wrong place for your configure.php.. Do you have a funky absolute URL on your webserver?

 

If after an install it's unable to connect to the database, I'd think that only 2 probs would exist here.. 1) The database being requested doesn't exist, or 2) your not calling it correctly where by you've specified the wrong database, or the script is looking in the wrong place for the configure.php.

 

Good luck !!

 

Ryan

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...