Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Unable to connect to Authorize.net gateway


lull45209

Recommended Posts

I've talked with Authorize about this problem, but they were no help. I've set up the admin with the correct Transaction key and username to log into Authorize.net, but I get an error no matter what I change in trying to make the SSL connection to Authorize. http://store.civa.org (try and log in and you'll see the error).

 

Authorize said the error was due to an incorrect log in name; but that's not the case (because it's right) and the Bank account info is correct; nothing seems wronng (I changed the Transaction key and copied and pasted it into the admin) ... but nothing works, I can't connect to Authorize gateway; what else do I need to try and do!?

Link to comment
Share on other sites

Ensure that the username and transaction key are correct. I had a customer that went around with Authorize.net for 2 weeks on something like this. Everytime they said that it was all correct. Apparently, he finally got fed up with eMail and called them. While on the phone someone noticed that the username was incorrect in the system and they changed it. Suddenly everything worked right. Yeah, I know; who would have figured.

 

I hope that is of some help to you.

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

I'm not sure how the username would be wrong when it's the same username I use to log into Authorize merchant area (unless it's not the same username). They said the account was active and I checked for the bank account number and it was all ok ... so I'm at a loss. I don't see anywhere on Authorize where I can change the username -- and I've reset the Transaction key a few times and copy and pasted it into OSC ... nothing works. I don't know what else the error might have to do with (except the account, which I'll double check with the client to make sure that it is correct).

Link to comment
Share on other sites

What error are you receiving exactly?

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

"The following errors have occurred.

(13) The merchant login ID or password is invalid or the account is inactive."

 

I called Authorize and told them the error and they double checked the account; it is still active. I told them the username I was using (spelled out - plus it's the one I log into the merchant area with) and there is no option that I find in OSC for a password, so I'm stuck as to why this is happening.

Link to comment
Share on other sites

  • 1 month later...

Although I just finished setting up EVERYTHING. I have this problem I have been messing with it for about an hour. I can login to authorize.net to change my settings with my username, I have this version: osCommerce 2.2 Milestone 2 (07/12/2003).

I have changed the Transaction Key in the authorize.net settings page, I used the login name that i use to login to the authorize.net web site, and I set the receit URL and the other one to the path that some guy in this board said to use, I have tried everything I can think of. Its 5am here now so I will call Authorize.net in the morning and *IF* I get a fix for this problem I will be sure to post it here. I read that someone else just had them change the username and woala! worked for them. I will try this if they dont know whats up.

Link to comment
Share on other sites

check your user name(id) with the one they send you in your email and the one you put in your admin section, check it three times if you have to. somehow i slipped a digit and i checked it twice and could have swore it was right, part of the reason its difficult to verify the username is because the issue it and you do not create it, there is lots of numbers and it can easily get mixed up, but this is great, It all working awesome for me, i havent gone into live mode yet, but test mode there was no problem

Link to comment
Share on other sites

The easiest way to prevent that is to copy the username information from the eMail and paste it into the osC admin. ;)

 

Thanks for passing along that information! I am sure that it will help a lot of users out.

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

  • 1 month later...

when you say configure your admin do you mean through the admin panel settings for authorize.net payment?

 

Totally new to this and i put in my username for the authorize.net and didnt work.

 

I am just reading about the transaction key and realize there is something else i am not doing? where do i put in the transaction key #.

 

I know there must be documentation on this kind of stuff somewhere, can anyone point me to the authorize.net with osCommerce help?

 

Thanks.. Mikey :oops:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...