Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Once Again I call upon the great ones..Help!


soulfinger

Recommended Posts

I was having trouble accessing my payment modules in the admin. I made the changes to the configure.php in the shop and admin directory. Everything worked fine. When I went into the payment module I saw all of the payment options but then I had an error. I went back to see the script and then for some reason I couldn't log back into the admin. When I tried to log back into the admin, it gave me the error message below. Does anyone know what this means and what I have to correct. Thanks

 

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/knoxie/public_html/shop/admin/includes/configure.php:55) in /home/knoxie/public_html/shop/admin/includes/functions/sessions.php on line 67

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/knoxie/public_html/shop/admin/includes/configure.php:55) in /home/knoxie/public_html/shop/admin/includes/functions/sessions.php on line 67

 

Warning: Cannot modify header information - headers already sent by (output started at /home/knoxie/public_html/shop/admin/includes/configure.php:55) in /home/knoxie/public_html/shop/admin/includes/functions/general.php on line 18

Link to comment
Share on other sites

Check your configure.php and see what's on line 55

 

If you have nothing there ... make sure that there are no spaces or blank lines after the ?> at the end of the file.

Link to comment
Share on other sites

I know you fixed it, but for anyone else who might be having trouble or looking up in a search (this might save you a few hours).

 

in the following directory

.../includes/configure.php

and

.../admin/includes/configure.php

 

change

'STORE_SESSIONS', ''

to

'STORE_SESSIONS', 'mysql'

in both files near the end of the file.

 

Minnelli

Link to comment
Share on other sites

I know you fixed it, but for anyone else who might be having trouble or looking up in a search (this might save you a few hours).

 

in the following directory

.../includes/configure.php

and

.../admin/includes/configure.php

 

change

'STORE_SESSIONS', ''

to

'STORE_SESSIONS', 'mysql'

in both files near the end of the file.

 

Minnelli

 

Good one to really point out ... you would be amazed how that little setting fixes so many things. And, it ups your security as well.

 

Thanks for making a note of that, Minnelli

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...