Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Admin shows Not protected by SSL?


Guest

Recommended Posts

hi people,

 

I have tried a second install of oscommerce 2.2MS1

 

I have SSL and both HTTP and HTTPS servers. When I go to any page like Login or Checkout, they go to the HTTPS server and I get the lock on the browser. When I go to the ADMIN panel, it says

 

( You are not protected by a secure SSL connection. ) with an open lock.

 

What can I do to fix this?

 

I have checked the use ssl box in the installation, and the variable is set to true

 

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

 

I could really use some help here. This site is for a museum shop and I want to make absolutely sure this SSL is working right before i put it up.

 

SOMEONE please..

 

Thanks

Link to comment
Share on other sites

just looked at admin index.php...

 

if (getenv('HTTPS') == 'on') {

$size = ((getenv('SSL_CIPHER_ALGKEYSIZE')) ? getenv('SSL_CIPHER_ALGKEYSIZE') . '-bit' : '<i>' . BOX_CONNECTION_UNKNOWN . '</i>');

$contents[] = array('params' => 'class="infoBox"',

'text' => tep_image(DIR_WS_ICONS . 'locked.gif', ICON_LOCKED, '', '', 'align="right"') . sprintf(BOX_CONNECTION_PROTECTED, $size));

} else {

$contents[] = array('params' => 'class="infoBox"',

'text' => tep_image(DIR_WS_ICONS . 'unlocked.gif', ICON_UNLOCKED, '', '', 'align="right"') . BOX_CONNECTION_UNPROTECTED);

}

 

 

Might spring some ideas?????????????????????????????

Link to comment
Share on other sites

Dude your the man! :D

 

I didnt even think of that 8)

 

 

It worked!!

 

But, you think you could tell me where to go change the path for the whole administration to https ???

 

if not its ok.. thanks man

Link to comment
Share on other sites

  • 3 weeks later...

idotcom,

I found the setting in the admin/includes/configuration.php file as a define function. Change the "define('HTTP_SERVER' " setting to be an https:// URL as well, and all of your administration configuration links will use it.

Link to comment
Share on other sites

I changed the setting

define('HTTP_SERVER' " to an https:// URL

I also load the main page via https.

I think everything works, the browser address always shows an https address, my mozilla shows the golden locked lock in the status bar.

HOWEVER, it still says 'you are not protected by a secure SSL connection' with an open lock on the main page.

Strange, isn't it? I think it has something to do with my webspace provider's SSL proxy.

Does anybody have an idea (not so important though) ?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...