Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Oscommerce not working


Adiemus

Recommended Posts

It does work on 4.3.2 , you probably have some settings in PHP.INI that need adjusting. If you give more info we might be able to help

"Politics is the art of preventing people from taking part in affairs which properly concern them"

Link to comment
Share on other sites

The problem in the shopping cart

it doesn't work

when i buy a product it appears in cart but

if i click "refresh" in browser it writes @your cart is empty@

and when i buy a second product the first one dissapear from shopping cart

 

Please help if you can

you will save my life ^)

Link to comment
Share on other sites

What contributions have you added to your shop?

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

clean ms1 version doesn't work too

 

configure.php

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

doesn't work.

 

here's the reply from provider:

 

"We have updated our software so from the moment on direct access to the session files is prohibited. You should disable direct access to session files in your scripts . Use php's built-in sessions procedures instead"

 

new php version is 4.3.2

Link to comment
Share on other sites

hi,

just installed ms1 and it seems really great. problem i have is:

when i log in it says "welcome, joseph!" but after i browse some products and add some to the cart then click on "catalog" it says "welcome guest!"; however, the cart shows the right product! when i try to check out it says my cart's empty but when i click on "cart content" it's all there.

I'm totally confused. what did i do wrong during installation/configuration?

thanks so much

joseph

Link to comment
Share on other sites

:?: I am a newbie to OSC and PHP, so I desperately need help on this issue.

I am using WIN ME with PHP 4.3.2RC4, Apache 1.3.27 and MySql 4.0.13.

I am tried both osCommerce 2.2-MS2-CVS and 2.2 MS2.

 

The problem I having right now is exactly the same as Adiemus. The item is in the cart but once you refresh puff it gone! I have tried searching through the forum but there is no solution. I have the tmp file in the root created. I am at the ends of my wits here.

 

Some topics refers this problem as PHP problem. OK, so how do I solve it? Please help, much appreciated.

Link to comment
Share on other sites

It is a PHP 4.3.2RC4 bug I had 4.3.2RC4 and could not get it working. I compled the latest 4.5-dev snapshot and all is well. So sorry the answer is don't use PHP 4.3.2RC4. Use the current stable release and wait for the 4.3.2 stable release.

Link to comment
Share on other sites

I should add

 

[29-May-2003] The PHP developers are proud to announce the immediate availability of PHP 4.3.2. This release contains a large number of bug fixes and is a strongly recommended update for all users of PHP. Full list of fixes can be found in the NEWS file.

 

Try that version.

Link to comment
Share on other sites

Thanks for the reply, I did change to the current 4.3.2. But its still the same. The shopping cart keep disappering!

No, I am not on Cpanel server. I am running on my own machine which is Win Me. I have tried Apache 2.0.45, but I get the same error. I tried checking out, but the system will prompt, "Shopping cart is empty".

 

 

Does any else have this same problem and managed to solve it?

Link to comment
Share on other sites

  • 1 year later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...