Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help Please - Global Variables Off


NickH

Recommended Posts

Hi.

The following is Shown when I try to intall the web site after uploading.

 

---

Warning: ini_get() has been disabled for security reasons in application.php on line 19

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

---

When I uploaded .htaccess with Global_registers=on the following was shown:

 

---

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

---

 

 

I know this is not a problem created by OsCommerce, but by the hosting company, but was wondering whether it is possible at all to run OsCommerce with global variables being off.

It is impossible for me to turn on global variables.

 

Thankyou very much in advance for you help.

 

Nick.

Link to comment
Share on other sites

the only answer i can give you is, go find a real HOST

if you want to start an online store then you have to pay for professional & maximum service.

For $8 - $... a month you can find a professional Hosting service,

so it's cheap

Robert

 

We all need to learn it once, how hard it may seem when you look at it, also you will master it someday ;)

Link to comment
Share on other sites

The entry in your .htaccess file should look like:

php_flag register_globals on

Fix that line and your problem will be resolved. ;)

"Great spirits have always found violent opposition from mediocre minds. The latter cannot understand it when a man does not thoughtlessly submit to hereditary prejudices but honestly and courageously uses his intelligence." - A. Einstein

Link to comment
Share on other sites

  • 3 years later...

My host suggested creating a php.ini file with register_globals = On in it, then uploading it to the server directory where it was needed. I found out I needed to put a separate file in the admin directory as well as the main store directory.

 

Works fine for me but I'm not too swift with code so others may have better suggestions! Good luck :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...