Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL activation in osCommerce.


Marcusantonio

Recommended Posts

I administer my website with H-Sphere, I activated SSL on my site. When I type https://www.mysite.com I do get the security alert, I am entering a secure site. But when I enter my store through http://www.mysite.com, and shop, it never gives me the security alert.

 

My questions are

 

1. Are there any files I will have to edit in osCommerce to enable SSL secure my customers credit card info during checkout? I know it is unreasonable to ask all my customers to type https every time they come to my site.

 

2. Is there any site that details the activation of SSL in osCommerce?

 

Thank you I appreciate your help

 

Mark

Link to comment
Share on other sites

If your SSL cert was properly installed and both your admin and catalog/includes/configure.php looks like this

define('HTTP_SERVER', 'http://your domain.com'); // eg, http://localhost - should not be empty for productive servers

 define('HTTPS_SERVER', 'https:your SSL url.com'); // eg, https://localhost - should not be empty for productive servers

 define('ENABLE_SSL', true); // secure webserver for checkout procedure?

you should be ok

 

HTH

The_Bear

Link to comment
Share on other sites

The_bear I thank you for response to my post. :)

 

 

In catalog/includes/configure.php , this configure.php file is identical to the one posted by The_Bear. The second file is the one located here admin/includes/configure.php. this configure.php file had the

( define('HTTPS_SERVER', 'https:your SSL url.com')  

It did not have

(define'HTTPS_SERVER',

and

('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

 

I followed the instructions where they applied and I still do not have a secured checkout.

 

Below is the parts that I have questions about

 

 

define('HTTP_SERVER', 'http://itrigger.com'); // eg, http://localhost or - https://localhost should not be NULL for productive servers

 define('HTTP_CATALOG_SERVER', '');

 define('HTTPS_CATALOG_SERVER', '');

 define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog

 

 

Do these servers need to be defined, and should ENABLE SSL_CATALOG be true?

 

I will appreciate any help

 

Mark

Link to comment
Share on other sites

  • 2 weeks later...

Mark,

 

I use HSPHERE and I had the same problem. The fix was simple and nothing to do with cinfigure.php files.

 

I had this problem because I installed OSC before I added my SSL. So I simply just reset my OSC by hitting the EDIT icon within HSPHERE. The only downside is that you modifications will be reset as well. Like your stylesheet.

 

As soon as I reset it, it worked fine. BUT HERE'S THER KICKER...

 

my configure.php files do not contain the modifications suggested on so many threads. When the code asks for you HTTP URL or your HTTPS url and things like that, mine are left empty and everything works fine. I have no idea why this is.

 

Hope this help.

 

By the way, I am using 2.2 MSI, not CVS.

Link to comment
Share on other sites

Thank you Carlo, You are right. It worked. Thank you, you made my day this early. 1 AM. Now I can sleep in peace after struggling with this for over 3 weeks

 

Marcus :D

 

No problem. I know what you mean. I have lost sleep ofver web sites many times as well. Glad it helped.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...