Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

create-account.php not found


kennyk2

Recommended Posts

I've just installed oscommerce and I notinced a small problem. When i click on the create a new account button, i get a DNS Page not found error. This has also happens with the login page.

 

Has anyone else experienced this problem?

 

Is there a fix?

 

Thanks

 

Ken

Link to comment
Share on other sites

Hello, I'm having this problem also. Here are what I think are the related settings from configure.php:

 

define('HTTPS_CATALOG_SERVER', 'https://www.ebbertonline.com');

define('ENABLE_SSL_CATALOG', 'false');

 

Is there another setting missing?

 

If I hover over the link to login, it is

http://www.ebbertonline.com/catalog/HTTPS_...talog/login.php

 

So there's an extra "/HTTPS_SERVER/catalog" in there. Thanks for helping.

Link to comment
Share on other sites

Hello, I'm having this problem also. Here are what I think are the related settings from configure.php:

 

define('HTTPS_CATALOG_SERVER', 'https://www.ebbertonline.com');

define('ENABLE_SSL_CATALOG', 'false');

 

Is there another setting missing?

 

If I hover over the link to login, it is

http://www.ebbertonline.com/catalog/HTTPS_...talog/login.php

 

So there's an extra "/HTTPS_SERVER/catalog" in there. Thanks for helping.

From what I see at your site, the above HTTPS_CATALOG_SERVER is in your catalog/includes/configure.php

 

It should not be there! This setting is supposed to be in admin/includes/configure.php. The same goes for ENABLE_SSL_CATALOG.

 

For your convenience, I include the catalog/includes/configure.php from the latest cvs. Please set HTTP_SERVER, HTTPS_SERVER, ENABLE_SSL, DB_SERVER, DB_SERVER_USERNAME, DB_SERVER_PASSWORD and DB_DATABASE to the appropiate values.

<?php

/*

 $Id: configure.php,v 1.13 2003/02/10 22:30:51 hpdl Exp $



 osCommerce, Open Source E-Commerce Solutions

 http://www.oscommerce.com



 Copyright (c) 2003 osCommerce



 Released under the GNU General Public License

*/



// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

 define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers

 define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

 define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

 define('DIR_WS_IMAGES', 'images/');

 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

 define('DIR_WS_INCLUDES', 'includes/');

 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');



 define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');

 define('DIR_FS_DOCUMENT_ROOT', $HTTP_SERVER_VARS['DOCUMENT_ROOT']); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');



// define our database connection

 define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers

 define('DB_SERVER_USERNAME', 'mysql');

 define('DB_SERVER_PASSWORD', '');

 define('DB_DATABASE', 'osCommerce');

 define('USE_PCONNECT', 'false'); // use persistent connections?

 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

Greetings from Marcel

|Current version|Documentation|Contributions|

Link to comment
Share on other sites

Thanks for the help, M@rcel. It's possible I mixed that file up with the /admin/includes one while trying to get the installation to work. I copied your code for /catalog/includes/configure.php and entered my database connection details and now the login link is working.

 

However, now I see the error "Warning: Cannot send session cache limiter - headers already sent (output started at /var/www/html/catalog/includes/configure.php:43) in /var/www/html/catalog/includes/functions/sessions.php on line 67" at the top of each page. Would you mind taking a stab at this one?

Link to comment
Share on other sites

  • 1 month later...

Had the same problem and fixed my catalog/includes/configure.php. Could you please post your admin/includes/configure.php?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...