Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

whois online problem


malcolm

Recommended Posts

For some reason we get an error message after someone just bought some stuff from our site. The site doesn't work at all. :-)

 

no doubt it's an easy problem to solve.

 

Can you please take a look and offer some ideas:

www.livingfaithbooks.com

 

Thanks very much!

Link to comment
Share on other sites

thanks

 

i've looked over the problem (our server uses php v4.3.1) and its solution (removing and recreating the existing whos_online table).

 

however, this is somewhat out of my competency range to actually understand and fix. :-)

 

i have gone ahead and restored the database itself from a previous backup and that has brought the site back up. Although only for now apparently.

Link to comment
Share on other sites

I checked the site and re-did the table to be sure all was happy.

 

Should this happen again, in phpMyAdmin you can remove and remake the table with the same command I used:

 

DROP TABLE IF EXISTS whos_online;

CREATE TABLE whos_online (

 customer_id int,

 full_name varchar(64) NOT NULL,

 session_id varchar(128) NOT NULL,

 ip_address varchar(15) NOT NULL,

 time_entry varchar(14) NOT NULL,

 time_last_click varchar(14) NOT NULL,

 last_page_url varchar(64) NOT NULL

);

 

Be sure to keep current backups! :D

Link to comment
Share on other sites

I have a few stores of varying CVS vintages that are having the same difficulty

 

Yes they are on CPanel servers that were upgraded, but then they were downgraded cause of all the mysql 4 issues.

 

I have a few stores that give the following error when going into the default.php page:

 

Query was empty - Query was empty  

 

Query was empty  

 

[TEP STOP]  

 

Query was empty - Query was empty  

 

Query was empty  

 

[TEP STOP]  

 

 

Warning: Unknown(): A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0

 

 

and all i get is a blank white screen with this error.

 

I have sessions stored in mysql and i have deleted and reinstalled the whos_online table and the errors continue.

 

I find if i do a forced browser refresh a few times then the page loads and all is ok, until the next day when the same thing happens again.

 

Anyone have any ideas on this one???

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...