Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

categories.php problem


OfficerGator

Recommended Posts

I looked through the posts hoping to find a solution without having to post this, if this is a repost, I apologize. I am just getting back into website development, and PHP is a little new to this old dog. Want to talk BSD or UNIX I am your man, but PHP solutions need to be in almost roadmap form for me, sorry! Problem is the following lines on the catalog pages, but it only shows up on the main page, checkout page and a few others, solutions?

 

Categories

 

Warning: Wrong datatype for second argument in call to in_array in /var/www/html/cr/cropperscorners.com/catalog/includes/boxes/categories.php on line 31

 

Warning: Wrong datatype for second argument in call to in_array in /var/www/html/cr/cropperscorners.com/catalog/includes/boxes/categories.php on line 38

 

Warning: Wrong datatype for second argument in call to in_array in /var/www/html/cr/cropperscorners.com/catalog/includes/boxes/categories.php on line 31

 

Warning: Wrong datatype for second argument in call to in_array in /var/www/html/cr/cropperscorners.com/catalog/includes/boxes/categories.php on line 38

 

Warning: Wrong datatype for second argument in call to in_array in /var/www/html/cr/cropperscorners.com/catalog/includes/boxes/categories.php on line 31

 

Warning: Wrong datatype for second argument in call to in_array in /var/www/html/cr/cropperscorners.com/catalog/includes/boxes/categories.php on line 38

Hardware-> (6)

Software-> (4)

DVD Movies-> (17)

 

Everything else works fine, and this is an out of the box install, I havent changed anything yet, for short means I dont think I broke it!!

OpenBSD Free, Functional, Secure. Choose Three!!!

Link to comment
Share on other sites

Clear your browser cache, including your cookies.... set osC to store sessions in the database....in both your configure.php files:

 

  define('STORE_SESSIONS', 'mysql');

Link to comment
Share on other sites

  • 10 months later...

:ph34r: Help :ph34r:

 

I am having this problem too, except, mine has suddeny just started to give this exact error, but usually only on the second visit to the site. Very weird since the site has been running without any issues for about a year.

 

Any advice will be well received.

 

Thanks again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...