Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Suddenly I have a strange IMAGE loading problem


valley

Recommended Posts

Your images are refferred to as .bmp Is this what you want? When I right-click a missing image, go to properties and copy the url to the image into the location-bar of my browser, it returns a 'forbidden' page. When I try to access the same image with a gif or jpf extension, a 'not found' is returned. I hope this info will help you to identity the problem.

Greetings from Marcel

|Current version|Documentation|Contributions|

Link to comment
Share on other sites

Hello Marcel,

 

Many thanks for pointing in the right

direction.

 

Eventhough I had checked the Permission

on the Images directory and found to be 777

for some mysterious reasons, most of the

individual files had no read/write permission

 

I have set the permission for all files to read write and

the images have come back, Many thanks.

 

I noticed that when the OSc is in the https area

like the shopping cart, they were being shown.

 

I haven't changed any permissions at all.

 

I wonder if there is a hidden copy of the image directory

in the https server which was serving the files

before and I somehow changed a password or something ?

 

Is that how it works ?

Link to comment
Share on other sites

A few things:

 

I noticed a double forward slash in the ssl-url's. My guess is that your setting for HTTPS_SERVER in catalog/includes/configure.php ends with a slash. This should be removed.

 

=================

 

Next, watching your non-SSL and SSL url's, I think that you're making use of a shared SSL-setup offered by your provider. Almost always this is configured to use seperate disk-space for SSL and nonSSL. The seperate areas are often on different physical servers.

 

If the above is true (in your case), you have uploaded the store twice, once for nonSSL and once for SSL. And then, yes, you do have two image directories. The admin interface updates only one of them, you have to synchronize them yourself. This could explain your 'hidden image directory'.

 

If your SSL and nonSSL are indeed on different servers, measures have to be taken to make the session-data available in both environments. This is done by setting the STORE_SESSIONS variable in catalog/includes/configure.php to 'mysql'.

 

===========================

 

I think it's a good idea to change the format of your images from bmp to gif or jpg. Because that way the graphics are size-optimized and your site will load faster (especially on slow dial-up links).

 

===========================

 

When I go into ssl on your shop, a warning is displayed about unsafe contents. This is propably caused by loading images from ... with http instead of https. It is caused by your footerbanner (the one below paypal-image). Perhaps your best bet here is to suppress this banner while in SSL. Something like:

 

if ($request_type == 'NONSSL') {

display banner

}

Greetings from Marcel

|Current version|Documentation|Contributions|

Link to comment
Share on other sites

Hello Marcel,

 

Many thanks for the insight in to setting up

https server correctly. Unfortunately very little is

explained in help documents for new comers

 

catalog/includes/configure.php ends with a slash. This should be removed.

 

This has been done

 

This is done by setting the STORE_SESSIONS variable in catalog/includes/configure.php to 'mysql'

 

Already set to mysql in the file

 

However I am not sure about the path of the image directory

 

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

 define('DIR_WS_IMAGES', 'images/');

 

 

Do I need to mention the full directory path of the secure server

before /images for define('DIR_WS_IMAGES' ?

 

I don't remeber having uploaded the image files seperately

but remember that the file path was mentioned like above

somewhere ( as I followed another thread about secure server

at that time where the WARNING message was dicussed.

Can't remember)

 

 

Perhaps your best bet here is to suppress this banner while in SSL. Something like:  

 

if ($request_type == 'NONSSL') {  

display banner  

}

 

Also done . BTW this is my very first PHP code

 

Shall appreciate if you can have another look as I have

never seen this notorious WARNING about unsecure cart.

Link to comment
Share on other sites

I got this message when clicking "checkout". It is definitely caused by the mixture of safe (= https://) and unsafe (= http://) contents in one page. All standard osc url's are created with tep_href_link function in catalog/includes/functions/html_output.php. The use of this function guarantees avoidance of the above problem.

 

I think you have hardcoded your banner-url's. Therefore they are always http:// url's, thus giving the warning. Avoiding the banner to display when in https:// (SSL) is a simple cure.

 

The path of your image-dir is ok. t is automaticcally prepended by HTTP_SERVER or HTTPS_SERVER and DIR_WS_CATALOG.

Greetings from Marcel

|Current version|Documentation|Contributions|

Link to comment
Share on other sites

  • 2 weeks later...

Hello Marcel

 

When I go into ssl on your shop, a warning is displayed about unsafe contents. This is propably caused by loading images from ... with http instead of https. It is caused by your footerbanner (the one below paypal-image). Perhaps your best bet here is to suppress this banner while in SSL. Something like:

 

if ($request_type == 'NONSSL') {

display banner

}

 

I have added your above suggestion to the banners in the footer

and is working well. I can't see thm in securepages

 

But my header images are required n every page

 

Iam still looking for this elusive copy of the image directory

in htpps server and can't find it.

 

I am not sure if changing the URL from http:// affiliatesexcel.com/catalog/images to

 

https:// affiliatesexcel.com/catalog/images will work

Link to comment
Share on other sites

I still get the error. It's caused by the oscommerce.gif in your site-news box. I guess you've hardcoded the url to this image. Try using a relative path:

<a </a ref="http://www.affiliatesexcel.com/catalog/catalog/default.php">

<img src="http://www.oscommerce.com/images/oscommerce.gif" BORDER="0" width="111" height="25"></a>

change to:

<a </a ref="http://www.affiliatesexcel.com/catalog/catalog/default.php">

<img src="images/oscommerce.gif" BORDER="0" width="111" height="25"></a>

Greetings from Marcel

|Current version|Documentation|Contributions|

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...