Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

ShipStaion for OsCommerce


Recommended Posts

This module allows you to import your orders from OsCommerce to ShipStaion for easy shipping – including creating shipping labels, sending shipping confirmation emails and comparing shipping rates for most of the North American couriers (including Canadian carriers: Canada Post and Purolator).

No core files changes are required – just adding one file and complete the setup from ShipStation.

Tested on 2.3.4 BS EDGE - should work on any version of 2.3

Here it is.... https://apps.oscommerce.com/RMpJA&shipstaion-for-oscommerce

Edited by greasemonkey
Link to comment
Share on other sites

  • 4 months later...
  • 11 months later...
  • 8 months later...

I know this is a pretty old topic but I was wondering if this contribution still works. I am trying to get it installed with shipworks however after following the instructions I keep getting errors when testing connection. 

Here is the error I've been getting no matter what I do:

Store Configuration

We received an error testing the Custom store: An error was encountered while attempting to test the connection
Any help will be greatly appreciated as my oscommerce store is the only one left that needs integration with SS. 
Link to comment
Share on other sites

Yes, Sorry I misstyped about shipworks. I Do have ship station and for some weird reason cannot get it to work. I tried to get it to work a while back when I did a 30 day trial. Now I am actually paying for SS and been trying to get it to work with OSC but keep getting errors. I tried putting the php file in my root dir as well as in the catalog dir. I then tried putting it in the admin dir and been getting "unauthorized" error from SS. One time I did get SSL connection error but could not replicate that error. I also get this error when trying to load the file directly (www.mywebsiteaddress/oscommerce/shipstation_osc.php):

Error on line 1 at column 1: Document is empty


Have you ever had issues with connection between the SS and your site? Any pointers of what I should look into? My OSC version is: 2.3.4 and I am using MTS Mini Template but I doubt this has anything to do with the issue. I suspect it is my .htaccess and or other security config? 


Link to comment
Share on other sites

@rastlin No I have not had any issues connecting this to any site.

The file goes in your root or catalog directory - the same place that you find files such as shopping_cart.php, checkout_shipping.php etc.

Example: http://www.mystore.com/shipstation_osc.php or http://www.mystore.com/catalog/shipstation_osc.php (you may have renamed the catalog like you mentioned above) http://www.mystore.com/oscommerce/shipstation_osc.php

If you use ssl/https on the catalog side of your store then you need to ensure (step 4 in the instructions) the path to the file in the shipstation setup is https (ie look at your index.php does it have https - yes or no).

Example: https://www.mystore.com/shipstation_osc.php or https://www.mystore.com/catalog/shipstation_osc.php (you may have renamed the catalog like you mentioned above) https://www.mystore.com/oscommerce/shipstation_osc.php

Make sure the admin credentials you used in the shipstation setup are correct.

Also, confirm, you have new orders in your store for SS to get and that your "pending" order status and the pending order status=1. You can confirm by navigating to https://mystore.com/admin/orders.php?status=1





Link to comment
Share on other sites


I've tried to get it to work for few more hours last night and this morning but to no avail. Keep getting same error from ShipStation. I triple checked all variables (URL, username, password, status IDs and made sure that everything corresponds with the settings in the OsCommerce) The Shipstation shows error when doing "test connection" or when I just hit "connect". The error is:
Store Configuration
We received an error testing the Custom store: An error was encountered while attempting to test the connection

I know it is finding the file php file as if I on purpose change the file's name I get not found error. I dont know how to run some type of a debug to see at which point the script fails. It also could be something with Ship Station as maybe they have changed something when initially setting up the custom store? I see that your contribution is from 2017 so even though you are able to run it and it works, maybe the initial set up from SS was changed?

Link to comment
Share on other sites

Nope, Cant connect. It will not let me through to whatever is the next screen or step within the SS. attached is a screen shots. 1st is from when I hit "Test Connection" 2nd is from when I hit "connect"


Thank you for looking and trying to help me. I really appreciate it. 






Link to comment
Share on other sites

Hi Brian @rastlin the file seems to be in the right place (just confirm the URL is correctly set in ShipStation - to the one I sent you in the PM).

And also confirm the Unpaid Status and Paid Status in ShipStation are correct as mentioned above. They should be;


paid1, paid

Edited by greasemonkey
Link to comment
Share on other sites

Everything seems to be working perfectly. The issue of No Connection during setup from Ship Station was due to little (stupid) setting within the OSCommerce. My cookies were being forced and this was blocking the connection from SS as SS was not able to use cookies when accessing the site. As soon as this option was turned off from within the OSC the installation from Ship Station was a success. I still had couple other issues due to too long strings that were in my database (payment string) as well as (shipping method string). I had to change those as well as make sure that the new orders would also meet the string length requirements. So far everything is working great. I really appreciate GreaseMonkey helping me look into his contribution and also Special thanks to George from Mini Template System contribution who jumped in and help me find the issue. 



Link to comment
Share on other sites

  • 6 months later...

I have a pretty old site which didn`t have a admin folder in the database, I created one and it still gives me the following error:

"Message":"Unable to connect to the marketplace! Error: The remote server returned an error: (401) Unauthorized."

If I comment the following out, ship station will connect but its not grabbing my processing orders which is id 2

//validate the password with the OsCommerce encrypted password
       // if (!tep_validate_password($pw, $admin_result['user_password'])) {
          //  header('WWW-Authenticate: Basic realm="ShipStation"');
         //   header('HTTP/1.0 401 Unauthorized');
          //  echo 'Unauthorized';
          //  exit;
       // }


my shop is v2.2 RC2a and any help would be greatly appreciated.

Link to comment
Share on other sites

I am able to connect now and it appears to be grabbing orders , I just cant see which ones. I had to move the file to the Admin folder for this to finally connect. Pretty sure this is not the correct folder but in the main directory I could not get it to connect. My site is so old and has tons of mods done to it so I am sure this isnt helping. Here is the error i am now getting from Ship station:

An error occurred attempting to update orders: Error in XML. Reason: The 'ShippingMethod' element is invalid - The value 'Standard Shipping Orders shipped using an economical carrier (i.e. USPS, FedEx, UPS) to arrive to you in 5-7 business days.:' is invalid according to its datatype 'String100' - The actual length is greater than the MaxLength value.


I changed this value to (5-7 business days) and updated all the processing orders to this shorter length. I am still getting this error, how does the date part of the code work? Is it looking at all the orders first before determining with ones to grab? hopefully I described my issue well enough


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...