Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

jQuery/Ajax Advanced Order Handler for osCommerce 2.3.3

Recommended Posts

Hi again. 

Finally, I've got it working! (At least locally, now I'm going to try it on my website)
Well, I was testing it on a local site which had some orders and customers created, etc. As I said before, I realized that errors came whith "All orders". Then I was picking one by one, and then I realized that the problem was with one specific status, "Processing" in my case, whic in table order_status, field id_order_status , had a value ot "2".
Then I created another status (Processing2, i.e.) which took id_order_status a value ot "12". I rearranged all orders with this new status, but again, I had the same error, just only with this two status... ¿¿¿???
Anyway, then I went to instructions (upgrading form Rev 2.3), and what I did was to reverse from Step #2 - in ./admin/includes/classes/order.php 

leaving those lines as follows:

      $orders_products_query = tep_db_query("select orders_products_id, products_name, products_model, products_price, products_tax, products_quantity, final_price from " . TABLE_ORDERS_PRODUCTS . " where orders_id = '" . (int)$order_id . "'");
      while ($orders_products = tep_db_fetch_array($orders_products_query)) {
        $this->products[$index] = array(
          'id'              => $orders_products['orders_products_id'],
          'products_id'     => $orders_products['products_id'],
          'qty'             => $orders_products['products_quantity'],
          'name'            => $orders_products['products_name'],
          'model'           => $orders_products['products_model'],
          'tax'             => $orders_products['products_tax'],
//          'tax_description' => $orders_products['tax_description'],
          'price'           => $orders_products['products_price'],
          'final_price'     => $orders_products['final_price'] );

Now it works fine (as far as I know, and pending on further testing).    Great!! I love it!!! Thx Dr.!!
(I forgot to tell that I installed it on a 2.3.4 BS Gold heavily modified...)

Shopowner, not coder, experienced copypaster  :D

Link to comment
Share on other sites

Hi all,
I'm testing this addon and I see that is a great contribution, but I regret to say that does not work fine.
I have corrected the problem that exist in ./order_handler/general_functions.php on line 631.

        if ( stristr( $value->title, $haystack ) ) {
          $default = $value->code;
          $selected_shipping = $value->title;


       if (!empty($haystack)) {
        if ( stristr( $value->title, $haystack ) ) {
          $default = $value->code;
          $selected_shipping = $value->title;


Now I have a problem to change the text or value of the shipping line.
I used the flat module and the changes are not updated.

Please, any suggestions.

Thank you!!!

Link to comment
Share on other sites

Having some problems that I can't figure out ... Installed Rev4 from scratch, running into the following issues:


1. 'Math' doesn't work ... the following error is produced:

FORMAT((AVG(FLOOR((DATEDIFF(CURDATE(), c.customers_dob) / 365)))), 2, @@lc_time_names) AS customers_mean_age FROM customers c WHERE (FLOOR((DATEDIFF(CURDATE(), c.customers_dob) / 365))) > 0 ' failed: Incorrect parameter count in the call to native function 'FORMAT'


2. Statistics works with a problem where "Customer Age" always returns "0" (I verified that DOB does exist for all orders)


3. Advanced Statistics: ONLY "Table Data" tab shows results.

Tabs for "Map" and "Color Map" return error "500: Internal Server Error" ...


Tabs for "Yearly", "Monthly", "Daily" and "Hourly" return similar errors like:

FROM_UNIXTIME(SUM(UNIX_TIMESTAMP(ci.customers_info_date_account_created)) / COUNT(*), '%Y-%m-%d %H:%i:%s') AS date, FORMAT((AVG(FLOOR((DATEDIFF(CURDATE(), c.customers_dob) / 365)))), 2, @@lc_time_names) AS customers_mean_age FROM customers c LEFT JOIN customers_info ci ON (c.customers_id = ci.customers_info_id) WHERE (FLOOR((DATEDIFF(CURDATE(), c.customers_dob) / 365))) > 0 GROUP BY YEAR(ci.customers_info_date_account_created), MONTH(ci.customers_info_date_account_created), DAY(ci.customers_info_date_account_created), HOUR(ci.customers_info_date_account_created) ORDER BY date' failed: Incorrect parameter count in the call to native function 'FORMAT'


4. When clicking "Edit Record" icon at right of a single row, all data is populated into the dialog correctly, however, upon clicking "SAVE" button all data for that record is wiped out with Null values (as if the cID is not being sent) AND the result says "New Account created for undefined undefined".


Any clues or help would be greatly appreciated!

Link to comment
Share on other sites

I was able to troubleshoot #1, #2 and #3 (in previous post) ... I removed "@@lc_time_names" from the FORMAT method, but ended up with the "fetch_all() undefined" error in my logs. I have a support ticket into my web host ... the shared web host phpinfo() is using PHP v5.4.10 and shows mysqli and mysqlnd installed, but for some reason it still doesn't work. I also cannot find a backwards compatibility anywhere for the "fetch_all()" method. I have been thru every page of this topic as well as the Advanced Statistics topics, tried everything possible, but no luck. ... I even tried setting flag for "register_globals" and "magic_quotes_gpc" to "off", but still no luck. ... Where/what is the code supposed to be for the fallback to tep_fetch_all ??? I cannot find it anywhere.

Edited by ClearVue
Link to comment
Share on other sites

  • 4 weeks later...
  • 2 months later...


First of all thank you for your contribution. I was looking for a good order editor.. and saw this contribution.

I installed it on a fresh 2.3.4 BS version. (only style addaptions)


When I open the order handler in admin I see a blank page and in the log file on the server I see:


" PHP Parse error: syntax error, unexpected '[' in ......./catalog/admin/includes/modules/order_handler/general_functions.php on line 575, referer: ...../catalog/admin/index.php   "


Line 575 in the general functions.php is:


574       function dump( $var ) {
-->  575           $backtrace = debug_backtrace()  [0];        <--
576           $fh = fopen($backtrace['file'], 'r');
577           $line = 0;
578           while (++$line <= $backtrace['line']) {
579           $code = fgets($fh);
580           }
581           fclose($fh);
582           var_dump( "\n$line: " . trim( $code ) . "\n________________________________________" );
583           var_dump($var);
584           die;
585       }



When I searched for the error message, I read that it might have to do with the version of php :

This is the info I get from the server with the admin tool server info:



MySQL 5.5.47-0ubuntu0.12.04.1


PHP Version: 5.3.10-1ubuntu3.16 (Zend: 2.3.0)


Any idea's what the problem can be...

Link to comment
Share on other sites

Since I'm not coder, so all I can do is read and try, test and see result.

So far only thing worked as in I did get a page, was to "ignore" that line by  // it.

Will this result in problems?

Edited by micdee
Link to comment
Share on other sites

Commenting out a line of code will usually cause a problem somewhere. That code was written for a reason, and you're removing it. For the line you are having a problem with, try removing the spaces, like this:

$backtrace = debug_backtrace()[0];

If that doesn't work, replace that line with this code:

$temp = debug_backtrace();
$backtrace = $temp[0];



See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

  • 2 weeks later...
  • 5 months later...

Adding a new record on 2.3.4 receive: An error occured while communicating to the server. Looking at Google Developer Tools I see Parse error: syntax error, unexpected '$this' (T_VARIABLE), expecting function (T_FUNCTION) in /home/public_html/catalogqa/admin/includes/classes/order.php on line 40


any ideas why this is occurring?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...