Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

1146 error after new install


FatboysOffroad

Recommended Posts

Hi all,

 

I put Debian on an machine for the purpose of testing and evaluation and am trying to get OSC 2.3.3.2 running. The install seems to go okay but when I try to access the admin or store I get the error below.

 

I've discovered via phpmyadmin that the tables are not being created. I've searched the forum and web but haven't found anything that spells out what's happening or what the scripts should be doing. I have in fact created the database. configure.php seems to be populated with the info I give during the install. I can login to mysql via the commend line.

 

I've looked but can't seem to find anything that resembles an install error log. Note that my installation/configuration of my LAMP server could possibly be the culprit. It would be awesome if someone can point me in the right direction.

 

1146 - Table 'oscommerce.configuration' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

 

Thanks,

 

Jerry

Link to comment
Share on other sites

Run install/oscommerce.sql file for setup store into an empty database. But would be better to install oscommerce by a standard way as everybody do that.

:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Link to comment
Share on other sites

On page 1 of the install there are 4 fields that deal with the database. They are labeled Database Server, Username, Password, and Database Name. I don't see a Server Requirements box or anything of the like. Makes me wonder if I'm looking at the right pages.

 

I've looked at the Apache log and nothing pops up when I run the install. I'm looking to make sure the php log is running.

 

Jerry

 

Hi Jerry..

 

Was the MySQL extension shown as being available in the Server Requirements box on the installation index page?

 

Could you review your web server and/or PHP error log and see if any errors were logged?

Link to comment
Share on other sites

I feel dumb. I did find this in the Apache log:

 

[Mon Sep 09 20:12:29 2013] [alert] [client 192.168.1.106] /home/<user>/public_html/oscommerce/ext/.htaccess: Options not allowed here, referer: http://192.168.1.5/~<user>/oscommerce/install/install.php

 

Hi Jerry..

 

Was the MySQL extension shown as being available in the Server Requirements box on the installation index page?

 

Could you review your web server and/or PHP error log and see if any errors were logged?

Link to comment
Share on other sites

If your server does not permit Options -Indexes, that's easy enough to get around. Just add a dummy index.html or index.php in every directory that doesn't have one already. It can just say "Nothing to see here, folks. Move along." or it can redirect the nosy visitor to the main store page. If you have some sort of admin control panel for the server, see if it has some option to suppress index generation. Usually that results in putting Options -Indexes in the .htaccess, but maybe they have some other way.

Link to comment
Share on other sites

Jerry, how did you get to the install/install.php page when there is javascript in install/index.php that would not have shown the "Start" button? As jQuery was not loaded due to that Options -Indexes problem, that continue button would not have been shown to you yet you somehow got to install/install.php.

:heart:, osCommerce

Link to comment
Share on other sites

Jerry, how did you get to the install/install.php page when there is javascript in install/index.php that would not have shown the "Start" button? As jQuery was not loaded due to that Options -Indexes problem, that continue button would not have been shown to you yet you somehow got to install/install.php.

 

I'll have to check later but I don't recall seeing a start button. I just plugged the url ending in /install/install.php into my browser and up popped page one prompting me for the db info. I'll try to get you an answer though.

 

If your server does not permit Options -Indexes, that's easy enough to get around. Just add a dummy index.html or index.php in every directory that doesn't have one already. It can just say "Nothing to see here, folks. Move along." or it can redirect the nosy visitor to the main store page. If you have some sort of admin control panel for the server, see if it has some option to suppress index generation. Usually that results in putting Options -Indexes in the .htaccess, but maybe they have some other way.

 

I have root access as this is a box I own which I built for the purpose of testing OSC. No production stuff here! There is no data on here that I will cry about should the whole thing turn into a smoldering mass of junk. I might shed a tear for the time lost in trying to get the silly LAMP server running though.

 

Jerry

Link to comment
Share on other sites

Problem solved. I bought my sister dinner and she came over and solved it in about 5 minutes (once we quit yakking.)

 

My apache2.conf (httpd.conf in apache-speak) had a userdir configuration that did not 'AllowOverride Options', so the Options lines in the .htaccess files were not being honored. This, obviously, broke the 'Options -Indexes' in the .htaccess files. Once she fixed that, everything worked fine.

 

Debian caused some of my confusion, as your documentation refers to the httpd.conf file, but Debian renamed this file to apache2.conf, and Debian also split the relevant userdir configuration section into yet another file down in mods-enabled/userdir.conf!

 

All my sister did was edit userdir.conf to append 'Options' to the 'AllowOverride' line and restart the server. After that everything in the installer worked perfectly and I now have a functional oscommerce.

 

The only mention of 'AllowOverride Options' we ever found is a single comment buried in the admin/.htaccess file. It would be very helpful if this line was expanded and placed into the pre-installation pages so that folks with less Apache experience would be alerted.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...