Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error message ?


mikesw15

Recommended Posts

Hi i keep getting this error message Warning: I am able to write to the configuration file: /customers/9/1/3/iwww/includes/configure.php. This is a potential security risk - please set the right user permissions on this file. I have tried changing the permissions but still keep getting it ?

Link to comment
Share on other sites

You need to change the permissions setting on the includes/configure.php file to 444 or less. there should be a way to do that in your control panel but if you can't find it, ask you host to point it out.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

If you are trying to change permissions via an FTP client, that often won't work. Many servers ignore chmod requests from FTP. Use your server control panel's file manager to change permissions. You want to make the file "read only", which is usually 444 permissions (although sometimes 644 will work, if PHP is not running as "owner").

Link to comment
Share on other sites

As Phil mentioned, the permissions can't be changed via ftp sometimes. If you can't change them via the control panel, I wouldn't expect you to be able to change them via ftp. You will need to contact your host and ask them to change the settings for you.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Changing file and directory permissions ("chmod") is one of the most basic operations in maintaining a web site. Any host which does not give you a way to do this, you should run away from as fast as your feet can carry you. I've never heard of a hosting control panel > file manager that doesn't let you change permissions. As I said before, many hosts do ban using FTP to change permissions, so you will have to use the file manager panel.

 

It is possible that for some reason (e.g., misconfigured FTP server) you do not have ownership of the files in question. If so, you will not be able to change their permissions using any method. You will have to have your host give you ownership (chown, which only they can do) and help you figure out why you don't own the files in the first place.

Link to comment
Share on other sites

I'm having the same issue. Changing it, whether in FTP or the server, doesn't stick. It just changes itself back. Chmodding it in the file manager gives a success message, but when the page is refreshed back to the file list, it's gone back to 644 again. Same with the FTP - I change it to 444, hit the apply button to change it, and then it changes back to 644.

Link to comment
Share on other sites

I'm having the same issue. Changing it, whether in FTP or the server, doesn't stick. It just changes itself back.

By any chance are you using cPanel? Their permissions interface has a nasty quirk to it -- it's possible to change the 3 numeric digits, but that will be ignored. You have to check and uncheck the 9 boxes for various permissions, and then save it. E.g., if permissions are 644, you can't simply overwrite the 6 with a 4. You have to uncheck the "write" checkbox for "owner".

Link to comment
Share on other sites

By any chance are you using cPanel? Their permissions interface has a nasty quirk to it -- it's possible to change the 3 numeric digits, but that will be ignored. You have to check and uncheck the 9 boxes for various permissions, and then save it. E.g., if permissions are 644, you can't simply overwrite the 6 with a 4. You have to uncheck the "write" checkbox for "owner".

 

I do use cPanel, and I always do the checking and unchecking of boxes, but it still reverts.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...