Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Glitch causing spontaneous color font change


jeu4328

Recommended Posts

Hello:

 

I logged into my eStore today, and it is doing something it has never done before. A few seconds after opening the eStore, the background color and font style spontaneously change (on the Navigation Bar and InfoBox Headings Bars) to different color and style.

 

Could someone please take a look at my website and tell me what the problem might be?

 

http://www.jewellsembroidery.com/shop/index.php

 

Thank you very much, Jewell

Link to comment
Share on other sites

I see you do have a parse error in stylesheet.css about line 21

 

#columnLeft .ui-widget-header, #columnRight .ui-widget-header, #columnLeft .ui-widget-header a, #columnRight .ui-widget-header a{color:#C6E4FC

}

}

 

Just one curly bracket to many

 

line 85 -87 is also wrong

 

//border-color; #e8dea0;

border-width: 0px;

border-style: solid;//

 

You can not comment out in stylesheet like this has to be

 

/*border-color; #e8dea0;

border-width: 0px;

border-style: solid;*/

 

again at about line 88 there is an error

 

Best thing is to check with

 

http://jigsaw.w3.org/css-validator/

 

or something similar a I see a few more errors that will cause problems nothing major but enough to cause problems.

 

Regards

Joli

To improve is to change; to be perfect is to change often.

 

Link to comment
Share on other sites

Joli, thank you so much for your help. I have no idea what I'm doing. I'm honestly surprised I'm not having more issues than I do!

I will go in and make those changes. I appreciate your feedback! :D

Link to comment
Share on other sites

You should google for web developer toolbar and use as an extension to your firefox browser

 

This tool will let you check , change and validate your css it adds a toolbar to your browser window as well as many other useful functions .

 

If you install go to css top left and click edit then just play about changes colours or something in your stylesheets the changes you make will be reflected immediately on your website.

 

As I say a lot of useful functions takes a while to learn how to use but I could not do without it now.

 

When you click the validate button you will see your problems and can then correct some are not so important or are soft errors but there are a few mistakes in your stylesheet which you will have to correct.

 

Practice makes perfect so give it a try think you done a really nice job with your website so far :thumbsup:

Good luck

Joli

 

PS: and remember always BACKUP before you do any changes saves loads of grief if you make a mistake

To improve is to change; to be perfect is to change often.

 

Link to comment
Share on other sites

Thank you so much, Joli. I appreciate your encouraging words. :)

I have so much to learn. It has been a bit overwhelming since I have no training and have no idea what I'm doing.

I would be lost without the help of you and others who have come to my rescue!

 

(Yes, I've learned the hard way about doing a BACKUP! ha! :blush: )

Have a terrific day! Jewell

Link to comment
Share on other sites

Hey, Joli :)

 

I just logged back onto my eStore, and it appears that I'm still having the same problem. <<sigh>>

 

Is there another tool that I can use to check the coding in other pages in FileManager to make sure there are no errors?

 

Thank you,

Jewell

Link to comment
Share on other sites

Hi ,

 

Do not see any problem attached is x 2 screenshots IE and Firefox

 

have I missed something or maybe do you need to clear your browser cache??

 

Regards

Joli

To improve is to change; to be perfect is to change often.

 

Link to comment
Share on other sites

have I missed something or maybe do you need to clear your browser cache??

 

At my end I am still be having the problem. It seems to happen after several seconds of accessing my store.

 

I've gone into Control Panel/Internet Options and deleted Internet History in Internet Properties.

 

Is there someplace else I need to go to clear out the browser cache?

 

I am using Chrome. Would that make a difference? And if so, why am I not having issues with any other site I access ... only mine?

 

Thank you, Jewell

Link to comment
Share on other sites

Does the site look right after the change, and before that the colors/styles are messed up? This can be caused by loading external files on a slow connection -- the site starts to display before all of the files are loaded, causing an incorrect display until all of the external stylesheets have loaded.

 

The fix for this (and incidentally to speed up your site's load time) is to move all of the stylesheet links ahead of the Javascript links in your template_top.php. Keep all of the stylesheets in the same order they are now, just move them above the Javascripts.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

Alrighty ... I THINK I've got the problem solved.

 

I had my son log onto my eStore on his computer through Safari, Chrome and FireFox. It was fine on each of them, so I thought there must be something wrong with my computer's system files. I restored my system files to a earlier version, and lo and behold ... it seems to be fine! :lol: Thank goodness!

 

I'm thinking this entire ordeal has been a great blessing in disguise, as I was able to correct the CSS errors you found.

I will also go in and make the changes you suggested in the template_top.php file.

 

Thanks so much for all your help!

 

Have a terrific weekend! :D

Jewell

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...