Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

USPS Module update for older versions


mhulbrock

Recommended Posts

I have a client in need to update to their USPS module. They are getting many errors, that I have found reffrence too at the below links, however all these fixes seem to be for versions 2.x and up. My client has no deiser to update his OSC version. Currently 1.28. I know updating the whole cart is the best way, but my hands are tied.

 

Errors incluide, incorret calculation for international.

Blank screen on checkout.

Priority Mail<sup>&reg;</sup> $13.63

 

And I fee there are other problem that step from this outdated modle.

 

Is there any info I can use or update avaiable for USPS OSC versions 1.2x

 

thank you.

 

http://www.oscommerce.com/forums/topic/369224-is-usps-shipping-module-down/

http://www.oscommerce.com/forums/topic/146950-contribution-usps-methods/page__hl__usps__st__840

http://addons.oscommerce.com/info/487

Link to comment
Share on other sites

The current USPS modules should work with your version. It has been so long since I've looked at anything before MS2 that I can't say for sure but as long as the module handling code is the same in that version, it should work. If not, and they still refuse to upgrade (probably a big mistake), then you will have to hire someone to convert it. That seems a silly decision though since the cost to convert probably wouldn't be much different than upgrading to version RC2.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

@@mhulbrock

 

There are more than likely MANY issues with your very out-dated version. I can't believe your hosting provider is still compatible with it. That was pre PHP 4.9. I would advise your client that nothing can really be done with it, save yourself a real headache and either convince the client its time for a new site, or just walk away from that house of cards.

 

 

 

Chris

Link to comment
Share on other sites

"1.28" is either an incredibly ancient, unsupported version (everyone who knew anything about it has died of old age by now), or you're looking at a template version (nothing to do with osC's version). If it's a template, you'll have to deal with the supplier of that template. Please come back to us with the correct underlying osC version.

Link to comment
Share on other sites

Anyone still running osC 2.2 MS2 is going to have a lot of work ahead of them updating the code to survive on updated hosts. Even 2.2 RC2a (the last of the 2.2 series) needs updating. Please seriously consider moving up to 2.3.3, the current version, and staying current as updates come out. Conversion isn't exactly painless, but will be less painful than sticking with something ancient. Would you use your '57 Chevy as your daily driver, through traffic jams and icy winter nights? Of course not -- it would be a show car; maybe take it out for a Sunday afternoon drive in nice weather. It's excusable to argue that your template is only for some 2.2 version, or you've got so many add-ons and code tweaks that you couldn't possibly abandon many of them and go to 2.3.3, but in the long run you've got to weigh the convenience of using certain non-standard features against "doing it right" with 2.3.3. Any add-on or template for 2.2 that you just can't do without could (in theory) be ported to 2.3.3 -- it might not be easy, but it should be possible.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...