Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Unable to get images to load even after permissions, htaccess, and url check. 500 error


lextech

Recommended Posts

I have done the normal checking to see if my htaccess file has any deny all commands, I have checked permissions and put them at 755, I have checked the URL tree to see the files are in the proper directory, and I still cannot get my images to show. I checked to make sure they weren't utf-8 at the end of the url. I am getting 500 server error. Below I have included images of the screen to show you where I am with this issue. It is clearly showing path and permissions, see what you think. Any advice is welcomed and appreciated.

 

Back story: Just loaded a fresh OSC install on a new server and built the database and site from bits and pieces of the old site. Trying to build the new site to have all the old site information and pictures.

 

 

See screens:

 

http://i32.photobucket.com/albums/d5/audiogodz1/ScreenShot2013-07-20at45225PM.png

 

http://i32.photobucket.com/albums/d5/audiogodz1/ScreenShot2013-07-20at44553PM.png

 

http://i32.photobucket.com/albums/d5/audiogodz1/ScreenShot2013-07-20at44648PM.png

 

Thanks! :)

RC2.2a

Link to comment
Share on other sites

So what was it -- hotlink protection? Your description was a little confusing -- Internal Server errors that involved only images?

 

HT file hidden in the tree that only showed on the FTP

Most hosting file managers have a switch to "show hidden files" (i.e., those beginning with a period, such as, oh, .htaccess).

Link to comment
Share on other sites

  • 2 weeks later...

What?! Options -Indexes prevents an "index page" from being automatically generated if there are no real index.* pages in the directory. It makes it harder for hackers and such to snoop around your site. It has nothing to do with "almost every image broken". One of two things happened: either you transferred (FTP) your image files in "ASCII" mode, which will corrupt them, or you had "hotlink protection" installed and didn't have your site in the whitelist. If the problem went away when you deleted Options -Indexes, that means your provider fixed something behind the scenes.

Link to comment
Share on other sites

Hi

 

Had a similar problem a while back because of this option -indexes I removed and ok

 

Can not remember now if it broke the images or jquery

 

But seen it has a security risk so changed servers.

 

Regards

Joli

To improve is to change; to be perfect is to change often.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...