Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

$oscTemplate->getTitle() won't render shop name in some files


altoid

Recommended Posts

Trying to figure out why $oscTemplate->getTitle() won't render the shop name to put in the store title in a couple cases.

 

This is occuring in the headtags modules, specifically ht_category_title and ht_product_title. But it is working the ht_manufacturer_title file.

 

So for the first two my page meta/title looks something like

 

My Great Category,

My Great Product,

 

Note there are commas at the end there.

 

But for the manufacturer the page title is rendering

 

 

A Great Manufacturer, My Shop Name.

 

The code rendering the manufacturer page appears to be :

 

$oscTemplate->setTitle($manufacturers['manufacturers_name'] . ', ' . $oscTemplate->getTitle());

 

While for the pages not work it is:

 

$oscTemplate->setTitle($categories['categories_name'] . ', ' . $oscTemplate->getTitle());
and
$oscTemplate->setTitle($product_info['products_name'] . ', ' . $oscTemplate->getTitle());

 

Respectively.

 

Ideas?

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Link to comment
Share on other sites

rewriting a response ....

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Link to comment
Share on other sites

@@burt

 

for the working manufacturer ht file: ht_manufacturer_title

 

function execute() {
 global $PHP_SELF, $HTTP_GET_VARS, $oscTemplate, $manufacturers, $languages_id;

 

for the category and product title ht title files

 

function execute() {
 global $PHP_SELF, $oscTemplate, $categories, $current_category_id, $languages_id;

 

and

 

function execute() {
 global $PHP_SELF, $oscTemplate, $HTTP_GET_VARS, $languages_id, $product_check;

 

This is occurring with both 2.3.3 oob files and the new version of those files for 2.3.4

I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...