Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Anyone experienced the same issue with SSL?


Recommended Posts

A long shot, but here's my problem.


I have self signed ssl certs for testing an ssl setup... I do have dedicated server, setup virtual hosts for both ports 80 and 443.. everything apears normal, everything works fine on all basic test sites, until I come to the one with OSCommerce on it.


I've updated both configure.php files.


normal access on http works fine.. then click something like "login" which wants to take me on https and I get the option to download the login.php file as apposed to just running the php file.


** this ONLY happens on HTTPS connections **


I've tried modifying the .htaccess to addhandler application blar blar blar, but that throws up two entirely new problems - the Http stops working all together with an internal server error, and the https goes streight to a forbiden saying you dont have permision to "/".


anybody seen the same or a similar issue that could help point me in the right direction of blogs etc



Link to comment
Share on other sites

fixed it


My solution (may not work for you):


depending on your setup, try adding the following to your httpd.conf:


AddHandler php-script .php


then restart apache


!!! BUT !!! remember to clear your browser cache first before testing :P otherwise you wont see it work :)


single handedly fixed the problem for me.

Link to comment
Share on other sites

@@Sumisu If you are using a local setup to test your site, don't bother with an ssl. If this is for a live shop, don't use a self-signed cert or all of your customers will meet with a security warning.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...