Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Link "jumps" on IE 10


Op999

Recommended Posts

  • 2 months later...
  • 2 months later...

I to do not use images for subcategories and noticed the problem only today when I looked using IE10.

 

To fix this I changed the valign="top" to valign="bottom" within index.php

 

Find:

while ($categories = tep_db_fetch_array($categories_query)) {
 $rows++;
 $cPath_new = tep_get_path($categories['categories_id']);
 $width = (int)(100 / MAX_DISPLAY_CATEGORIES_PER_ROW) . '%';
 echo '	 <td align="center" class="smallText" width="' . $width . '" valign="top"><a href="' . tep_href_link(FILENAME_DEFAULT, $cPath_new) . '">' . tep_image(DIR_WS_IMAGES . $categories['categories_image'], $categories['categories_name'], SUBCATEGORY_IMAGE_WIDTH, SUBCATEGORY_IMAGE_HEIGHT) . '<br />' . $categories['categories_name'] . '</a></td>' . "\n";
 if ((($rows / MAX_DISPLAY_CATEGORIES_PER_ROW) == floor($rows / MAX_DISPLAY_CATEGORIES_PER_ROW)) && ($rows != $number_of_categories)) {
 echo '	 </tr>' . "\n";
 echo '	 <tr>' . "\n";
 }

 

 

And replace the word top with bottom.

 

Viewing the source of the page will show something like:

<td align="center" class="smallText" width="33%" valign="bottom"><a href="http://collectable-cards.com/alfa-romeo-c-552_584.html"><br />Alfa Romeo</a></td>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...