Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error in line 300 Application_top.php


Reco-X

Recommended Posts

Hi i have this error and i don't know why, is a clean installation

 

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in C:\xampp\htdocs\catalog\admin\includes\application_top.php on line 157

 

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\catalog\admin\includes\application_top.php on line 157

Link to comment
Share on other sites

What version of osCommerce? Downloaded from here or a third-party installer? What version of PHP?

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

well, the story is this, i'm downloading templates around internet ALL the templates i download i must to install OSCOMMERCE, the versions are around 2.1 to 2.3.1

 

I'm trying to install this now:

http://www.mafiashare.net/download/tm33122-templatemonster-music-store-oscommerce-template/

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in C:\xampp\htdocs\catalog3\includes\application_top.php on line 300

 

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\catalog3\includes\application_top.php on line 300

 

____________________________________________________________________________________________________________________

 

and there is the error, but when i try to install this

http://www.templatemonster.com/free-oscommerce-2-3-1-template.html

 

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in C:\xampp\htdocs\catalog222\admin\includes\application_top.php on line 167

 

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\catalog222\admin\includes\application_top.php on line 167

Link to comment
Share on other sites

The "templates" that you are trying to use are really modified copies of osCommerce. Most of the "monster" templates are poorly coded and difficult to use or modify. They usually don't support their modified code, and we can't, so you're on your own.

 

Given all that, your template has a coding error. You should ask your template vendors for a version that uses osCommerce 2.3.3. Do not attempt to use any template older than 2.3.1. The 2.2 series of osCommerce is obsolete and won't work correctly on any modern server.

 

If you insist on running a template designed for 2.3.1, you'll have to apply the upgrades from osC 2.3.2 and 2.3.3 This is a lot of work, and will be complicated by the changes your "template" introduces. I hope you have a good working understanding of PHP -- you're going to need it.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

I'm guessing you messed up your installation attempting different things.

As far as I know, the different templates are for the catalog (customer) side of things, while your error shows and error under the admin side.

 

Still the remarks made above stay valid.

KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...