Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

installation error chmod 777


titanictees

Recommended Posts

Hi all I am new to this and need help I was trying to complete a new instalation and go this message

 

"The webserver is not able to save the installation parameters to its configuration files.

The following files need to have their file permissions set to world-writeable (chmod 777):

D:/Hosting/10865908/html/catalog/includes/configure.php

D:/Hosting/10865908/html/catalog/admin/includes/configure.php"

What do I do please

Thank you in advance

Link to comment
Share on other sites

Hi all I am new to this and need help I was trying to complete a new instalation and go this message

 

"The webserver is not able to save the installation parameters to its configuration files.

The following files need to have their file permissions set to world-writeable (chmod 777):

D:/Hosting/10865908/html/catalog/includes/configure.php

D:/Hosting/10865908/html/catalog/admin/includes/configure.php"

 

What do I do please

 

Thank you in advance

 

You're on a Windowz server. They don't have "numbered" permissions.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Hi all I am new to this and need help I was trying to complete a new instalation and go this message

 

"The webserver is not able to save the installation parameters to its configuration files.

The following files need to have their file permissions set to world-writeable (chmod 777):

D:/Hosting/10865908/html/catalog/includes/configure.php

D:/Hosting/10865908/html/catalog/admin/includes/configure.php"

 

What do I do please

 

Thank you in advance

"777" permissions are for UNIX systems.

 

The Windowz equivalent is "Read/Write" (as opposed to "Read only")

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

On Windows, more specifically, remove any "Read Only" attributes from the resource in question. I don't know how many "classes" can get different R/O attributes added (I think there's the owner, and general Web visitors, but there may be more, such as site services).

 

BTW, the instructions to set permissions for the configure.php files to 777 are stupid and plain wrong. First of all, it's very rare that PHP files need the "execute" bit set. Start with 644 (R/W for the owner, R/O for everyone else), which is the normal default for a file. The Windows equivalent would be to remove any "Read Only" attribute for the owner. If osC or PHP complains that it can't write to the files, try 664 and finally 666 (removing "Read Only" for system services or even for everyone). Once you have configure.php set up, you will be asked to make it Read Only for everyone (444, although 644 may work), so that PHP/osC can't accidentally (or through malicious manipulation) overwrite it. And if these faulty instructions are officially provided by osC, please fix them immediately!

Link to comment
Share on other sites

  • 1 month later...

I am having the same issue on a hosted Windows server. The only file access that I have is via FTP and the server's ftp does not allow changing file permissions. There is a way to ensure that a file is "editable" which I assume means that it is not R/O. So I verified that setting for both of the files yet that error message continues to be displayed. Is there anything else that I can do before I resort to attempting to get support from the web hosting service?

Link to comment
Share on other sites

That issue was rectified by the web hosting techs: they added write permissions to the file. Gah... last time I sign up with a hosting solution that does not allow me to control my own files!

Link to comment
Share on other sites

Many servers are set up to ignore FTP-origin requests to change permissions (as a security measure). Your hosting control panel will have the equivalent function somewhere in its File Manager. It's even possible that you'll have to go to the command line and use the attrib +r command to add Read-Only (-r to remove). I don't know about doing this for various "classes" of users (owner, system, others).

 

Windows defaults to Read-Write for all files, for at least the owner. Someone added "Read-Only" (attrib +r) to that file. There must be a way in the File Manager to change permissions, unless you have a very odd host.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...