Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Version 2.3.3 to version 3.1


synergy2013

Recommended Posts

Hi, i had a question and i know it may be premature. i am in the process of installing version 2.3.3, however since, version 3.1 could come out at anytime. I am wondering, does anyone know wheter the template system used in version 2.3.3 will be compatible for version 3.1 when it comes out? I asked this because, it almost seems like it would be a pain to install 2.3.3 and then 3.1 comes out next month and the template system is completely different. And i would have to redo the entire site all over again. So if anyone knows whether they will be compatible, it would be great! thanks.

Link to comment
Share on other sites

@@synergy2013

 

lol@ 3.1 being out anytime.......you mean anytime in 2014 ? maybe. And as far as I know, v3.x will not be compatible with any of the 2.x versions.

 

 

2.4 will be released soon though...

 

 

 

Chris

Link to comment
Share on other sites

2.3.3 is the latest stable version.

 

2.3.3 add-ons/templates will be compatible with 2.3.4 when its released, but will not be compatible with 2.4+ or 3+

Link to comment
Share on other sites

i had to complete disable the credit card components

 

I hope you weren't running the old "cc" module. That was never intended to be production code, only an example template for developers. It has been removed from 2.3.x because it does not meet PCI-DSS security requirements and its use could leave you (both developer and store owner) open to massive penalties.

 

Don't even think about waiting for 3.1. Given the development speed of osC, it could be anywhere from a few months to a few years down the road. Get up to 2.3.3 and stay current after that, and you'll be in good shape.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...