Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Following error code after host upgraded server.


collector1

Recommended Posts

Hi, my host has upgraded his server and I now can not see my site due to the following message:-

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /home/---/public_html/includes/application_top.php on line 279

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /home/-------/public_html/includes/application_top.php on line 279

 

Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/------/public_html/includes/application_top.php on line 279

 

I'm not very good with php and this is confusing me. Could any one please advise which code to change in which folders.

 

Many Thanks

Link to comment
Share on other sites

Can you be more specific about "upgraded his server"? Upgraded PHP version? MySQL version? Apache server version? Something else? That might give us a clue as to why it suddenly stopped working.

 

If you do a search in this forum for the first error string you reported, you'll find it has been discussed hundreds of times. I have suggested a number of possible fixes, but I never get feedback about whether they've been tried and whether they worked. The $language variable is not always being set in application_top.php.

Link to comment
Share on other sites

Hi

 

PHP version = 5.4.12

MySQL =5.5.30-cll

Apache = 2.2.23

 

oscommerce version 2.3.1

 

I have tried adding $language='english'; after // set the language in admin\includes\application_top.php and includes\application_top.php as per a previous post but this has worked for me.

 

I would have thought Warning: require(includes/languages/.php): should point towards languages/english.php but it does not.

 

Thanks

Link to comment
Share on other sites

Warning: require(includes/languages/.php): should point towards languages/english.php but it does not.

 

It sounds like you forced $language = 'english'; in the wrong place, so it's still unset at the point where you get the warning (which is still telling you that $language is unset). Furthermore, there is a $languages_id variable that needs to be set, too. It wouldn't hurt to upgrade to 2.3.3 and see if that improves the situation; they may have some improvements in that area.

 

If it still fails, I recently posted a huge rewrite to that section of application_top.php that is intended to make sure that $language and $languages_id are properly set, and it honors the store's default language setting before using the browser language setting. You might give that a try.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...