Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

new installation problems


alltooledup

Recommended Posts

Hi i am really new to the and i have this error came up when i have started installing

 

 

New Installation

 

The webserver is not able to save the installation parameters to its configuration files.

The following files need to have their file permissions set to world-writeable (chmod 777):

/Applications/XAMPP/xamppfiles/htdocs/alltooledup14/admin/includes/configure.php

Please correct the above errors and retry the installation procedure with the changes in place.

 

Can anyone please help

Link to comment
Share on other sites

The configure.php should NOT be 777. Those instructions are gravely in error. You start with 644 and try that. If it complains it can't modify the file, try 664. Only as a last resort try 666. Many servers are set up to forbid access to "world writable" xx2, xx6, or xx7 files and directories. BTW, is this a Linux (Apache) or Windows (IIS) server? Don't forget that you have to make the files Read-Only (usually 444) when you're done setting up.

Link to comment
Share on other sites

First of all, if you don't know how to change permissions on your PC, you shouldn't be using XAMPP (or WAMPP, or LAMPP). You should be on your real server (assuming you already have one and are not just playing with osC to see if you want to set up a site). Password protect the root directory to keep out search engines and nosy people until you have your site ready to go live. If you don't have a site yet and are just experimenting, *AMPP is OK, but you need to learn how to use it.

 

Are you on a Windows PC or Linux? 777 is not that deadly if you're the only one who can get to the machine, but you shouldn't get into the habit of making directories or files 777. It's a very bad thing to do on a live server on the Web. For a Linux box, the command is chmod 777 file path and name. I suspect that 644 (or maybe 664) would do just as well for you, and perhaps the file is already Read-Only (444). On a Windows box, if you had set the file to Read-Only (attrib +r file path and name), use attrib -r file path and name to make it Read-Write.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...