Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Google bot, 302 and cookie_usage.php - help


hobievi

Recommended Posts

When we analyse our site, around 4000 links have 302 redirects, which is not acceptable SEO wise. Googlebot is trying to add the product to cart (xxxxxxxx/products_new.php?action=buy_now&products_id=829) and being redirected to cookie_usage.php page (since its a bot i guess).

 

Whats the resolution for this without annoying the real customers. Is there a way to disallow clicking CART buttons?

 

Below are cookie/session settings. Maybe not to prevent spider sessions or what?

 

Force Cookie Use False icon_info.gif Check SSL Session ID False icon_info.gif Check User Agent False icon_info.gif Check IP Address False icon_info.gif Prevent Spider Sessions True icon_arrow_right.gif Recreate Session True icon_info.gif Prevent Spider Sessions

Thanks,

Yavuz

Link to comment
Share on other sites

- Can it be that i add cookie_usage.php as disallow to robots.txt (but then maybe i will get 404 errors this time)?

- I saw in some topics that there maybe a code to prevent add to cart button if there is no session id. Possible?

Thanks,

Yavuz

Link to comment
Share on other sites

You should be able to use robots.txt to tell Google etc. not to follow links into specific routines (e.g., /products_new.php), or with specific actions (*action=buynow*). That should keep the bot from following the link the button provides. It shouldn't result in a 404. The bot understands that it is not to follow a certain kind of link.

Link to comment
Share on other sites

When we analyse our site, around 4000 links have 302 redirects, which is not acceptable SEO wise. Googlebot is trying to add the product to cart (xxxxxxxx/products_new.php?action=buy_now&products_id=829) and being redirected to cookie_usage.php page (since its a bot i guess).

 

Whats the resolution for this without annoying the real customers. Is there a way to disallow clicking CART buttons?

 

Below are cookie/session settings. Maybe not to prevent spider sessions or what?

No, you should leave Prevent Spiders on. It might be that your spiders file is not up-to-date. There is an addon for that so you should check it. You should also add the following to your robots file

Disallow: /*action=*

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...