Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

OSC 2.21 Attribute Problems


architect

Recommended Posts

Hi All,

 

OSC 2.21 running on a Linux server, PHP5

 

Database size 39.6Megs

 

 

I have a client with a store selling fishing tackle with approximately 1000 products. There are a lot of product attributes, theoretically (see why theoretically later) 45 Product Options and 900 Option Values. Until a couple of months ago everything was working absolutely perfectly until one day he tried to add a couple of attributes to a new product. He created the product and as the attributes were also new, created the Product Option and then created the Option Values, there were only 2 values. He then used the Attribute Manager (very old version, not the Ajax version) to edit the attributes. The attributes were not saved. He didn't think much about it, just one of those things, I was on holiday and instead of emailing, he just rand and didn't leave a nesssage! He thopught the problem had gone away until 2 months later when the same thing happened. This time he then emailed me and asked me to try and fix the problem.

 

I tried the obvious steps of deleting the product and recreating it and adding the attributes - same problem.

 

I tried deleting the product, Product Options and Values, closed everything down and restarted the server. Recreated everything - same problem.

 

Tried sticking the torn hair back on with superglue.

 

Tried something a little off the wall. Recreated the product again and gave it attributes from another Product Option, that worked. The options saved correctly and were displayed on the front end. Tried adding the option we actually wanted inside another Production option set - that worked but obviously that isn't very satisfactory.

 

Next step was to download the whole site and replicate it on my test server. 480megs download and upload later, create a new database, import the old one and hack the config files, it's all up and running. But of course the problem still exists.

 

More head scratching.

 

The problem has to be with the database. Yes, I did back it up to my local computer and then ran the PHP database check - no problems reported. So I ran the repair utility - no problems reported.

 

Head getting very scratched now and I been at this for 8 hours.

 

Decide to start going through every Product Option and see if anything hits me. And a couple of things did:

 

1 - In the Product Options hardly any option had a length set, i.e. the comment length. Did some checking and found that it didn't seem to make any differenec to the front end product display whether or not a comment lenght had been set.

 

2 - I found that several Product Options were missing. What I mean is this - when you create a Production Option it is given a sequential number so that the first one gets number ONE, the second on created gets TWO and so on. This database does not have number 1 or 2, it is then OK until we get to 21, 22 is missing, then all OK until 33 and 34 and 35 are missing. I cannot think of any logical reason for this and I wonder if this is causing the problem.

 

 

For those of you who have taken the time to read this, thank you. Even more thanks if you have any suggestions of how I can solve the problem. My own idea is to start deleting the Product Options one ata time and then recreating them but I have a sneaky suspicion that the problem will just appear again.

 

Any ideas and suggestions gratefully received.

 

Tim

Link to comment
Share on other sites

@@architect

 

I have a client with a store selling fishing tackle

 

 

You should have your client come onto this forum to hire a professional developer to correct the issues.

 

 

Chris

 

ps. There is no such version as v2.21

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...