Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Upgrade from V2.2 RC1 to which V?


deneb1992

Recommended Posts


  • Hello.

  • I'm french so I do apologize for my english.

  • I work since few weeks on a website which uses oscommerce V2.2 RC1. I think I have to upgrade it but I don't know what I have to do. Which version of Oscommerce I have to take? Is it an upgrade or a package?

thank you for reply

Link to comment
Share on other sites

@@deneb1992

 

Since you are many versions behind, I would suggest you create a NEW website using v2.3.3. There is no real upgrade path from RC1 and even if you were able to patch up to the latest version, you would end up with a 'frankenstore' (all pieced together) which is never as stable as a new store using the latest version.

 

 

 

Chris

Link to comment
Share on other sites

While a fresh start with 2.3.3 would be best (and you can transfer the existing product and customer database, as well as product images), it may not be feasible if the 2.2 RC1 store is heavily modified (lots of add-ons and/or custom coding) or you are dependent on add-ons that have not yet been ported to 2.3.x. Try making a private test store off to the side, including transferring a copy of the database. If it runs satisfactorily, replace your current store with it. If it needs add-ons to restore function, you have time to see what's available.

 

If you judge that you must stay at 2.2, you should be able to upgrade to 2.2 RC2a (there may even be an add-on to do that somewhere). I believe that there is an add-on somewhere to make your base store PHP 5.3 compatible, although most add-ons will have to be manually fixed (deprecated function use, mostly). There are a number of security measures you need to implement, particularly removing some vulnerable administrative functions and protecting the admin directories. It's still a lot of work, and may be difficult to support, but at least you'll have a running, secure store. There is an upgrade to 2.3.x from there, but as Chris said, you'll end up with a hybrid "Frankenstore" that's probably more trouble than it's worth.

Link to comment
Share on other sites

Just a clarification: there are changes to the database between your version and 2.3.x. I'm not sure if there's an "update" script, or if you're going to have to compare the schemas by eye and manually update (with an editor) the old backup, to make it compatible with 2.3.x. You cannot directly use the old database with the new code.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...