Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Missing files after cart2cart.


Guest

Recommended Posts

Hi everyone,

 

I'm new to this forum and not very informed by how the osCommerce platform works so I hope I could get some help. I've been using the cart2cart service to migrate from osCommerce to Prestashop (have had PS before and with multishopping this is more convinent for me).

 

It all went fine until half an hour after the migration, until I ended up with this error at the osCommerce site:

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /customers/3/7/f/runshop.se/httpd.www/includes/application_top.php on line 321 Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/share/php') in /customers/3/7/f/runshop.se/httpd.www/includes/application_top.php on line 321

 

I haven't done anything to the FTP-files or the database (just cart2cart has been involved). I'd guess it's a file missing or something, but can't seem to find it. Any suggestions?

 

Kind Regards,

Oscar Troedson

Link to comment
Share on other sites

That would be:

 

Warning: require(includes/languages/.php): failed to open stream: No such file or directory in /customers/3/7/f/runshop.se/httpd.www/includes/application_top.php on line 321 Fatal error: require(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/share/php') in /customers/3/7/f/runshop.se/httpd.www/includes/application_top.php on line 321

 

I haven't done anything to the FTP-files or the database (just cart2cart has been involved). I'd guess it's a file missing or something, but can't seem to find it. Any suggestions?

 

Kind Regards,

Oscar Troedson

Link to comment
Share on other sites

@@sabio_proeliat

 

The osCommerce version you are trying to install is too old for the PHP version running on the server. You would have to update the osCommerce files in order to get it working. But, why do that if you are just going to prestashop anyway ? You don't need a working copy of osCommerce to do that, all you need is a copy of the database.

 

 

 

Chris

Link to comment
Share on other sites

Hi again,

 

No I didn't try to install a osCommerce version - I had a working site. Used the cart2cart service and then it broke down (so essentially this is for the cart2cart support but thought I could ask here as it's weekend an everything).

 

The reason I need the osCommerce to work is because my PR probably will drop if the site is down - and the PS version is not ready to go live. In addition cart2cart doesn't support Swedish characters so I need to copy paste product descriptions from the osCommerce site to PS.

 

Big thanks for your reply!

Link to comment
Share on other sites

@@sabio_proeliat

 

The error message you posted is normally attributed to incompatible PHP versions or PHP.INI setup errors. Other than that, I don't know what cart2cart does to a site during the conversion process.

 

Good luck

 

 

 

Chris

Link to comment
Share on other sites

Hello Sabio,

 

Sorry for this inconvenience. We will try to do our best to help you to solve this issue.

 

To see the exact reason of the error we should check your store migration. For that purpose, please contact our support team at support.magneticone.com/index.php?/Tickets/Submit They will help you with this problem.

 

Thanks for patience, sorry again.

 

Kind, MagneticOne

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...