Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Legacy Upgrade


neo719

Recommended Posts

I have inherited an OSCommerce installation from 2003 that appears to be a 1.x version. It has been white labeled, so I am not sure. Can anyone recommend an upgrade path? Are there any leaps I can make to update this old copy to the current versin without starting from scratch?

Link to comment
Share on other sites

You would first have to find out which version you are using. (usually can be found in this file includes/application_top.php ) Then you would have to upgrade to each new version after that one by one up until the latest version.

 

OR

 

Install a brand new 2.33 shop and import over the customers/orders/products/categories from the old db and start from there.

Link to comment
Share on other sites

@@neo719

 

 

When a site is that old, although you can upgrade it manually, what you would end up with is a 'frankenstore'. You can check your actual version by opening the /includes/application_top.php file and look around line 36 for the version.

 

However, I would recommend, as Nick said, re-creating your store using v2.3.3. It will be stable, secure and up to date.

 

 

 

Chris

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...