Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cannot Login To Admin Page, Reset Password And Still Won't Login


WickedMoto

Recommended Posts

I've been searching and trying all kinds of options and still can't login to my admin of my OsCommerce site; I have reset the password multiple times and when I set the password it says a manual login will still be required and then when I try to do that it says invalid; I have reset it numerous times in the cPanel and it still won't work....I also deleted it from the cPanel and then tried to make a new one from the actual admin login page and it still won't work. Can someone help me get this figured out?

 

Everything worked fine for the first year I've had the site and then a few weeks ago I was in the admin portion of the site and changed the passwords since the original web guy was no longer working with us and I didn't want him to have access. I changed the password and then after logging out it wouldn't let me back in under any of the users or passwords I had set. Please help! Thanks!

Link to comment
Share on other sites

@@WickedMoto

 

In the most recent version of osCommerce there is NEVER any reason to set a password through your cpanel. So, lets stop that.

 

The other thing you have to realized is that if you set .htaccess password protection from your osCommerce admin area, it will write to two files in your /admin directory. .htaccess and .htpasswd_oscommerce it will ALSO write the password to your database and it will encrypt it.

 

If you change your admin area password you MUST also change the .htpasswd file. This is normally done at the same time but in some cases that doesn't always happen.

 

The fix:

 

1) Truncate your administrators, action_recorder and sessions database tables using PHPMYADMIN in your hosting account.

2) Delete the .htaccess and .htpasswd_oscommerce files from the /admin directory on your server using your FTP client.

3) Upload a NEW copy of the two files to the /admin directory

4) Clear the cookies and temp files from your browser (Firefox, IE, Chrome, etc)

5) Direct your browser to your admin area (ie. www.yourdomain.com/admin/) where you will notice it tells you that there are NO administrators created and you will need to create one, so do that. Create a new username and password. The screen will refresh. Now, using your NEW username and password, log into the admin area.

6) Once you are logged in, click on administrators on the left column and you will see the warning saying the site is not secured with .htaccess protection. Select the new log in name and click to enable it. It may ask you to confirm the password....MAKE IT THE SAME PASSWORD YOU USED TO CREATE THE NEW ACCOUNT. If your browser asks you if you want to have the browser save the password and your computer is secure and only used by you, then click yes.

 

 

You are done !

 

 

Chris

Link to comment
Share on other sites

@@WickedMoto

 

In the most recent version of osCommerce there is NEVER any reason to set a password through your cpanel. So, lets stop that.

 

The other thing you have to realized is that if you set .htaccess password protection from your osCommerce admin area, it will write to two files in your /admin directory. .htaccess and .htpasswd_oscommerce it will ALSO write the password to your database and it will encrypt it.

 

If you change your admin area password you MUST also change the .htpasswd file. This is normally done at the same time but in some cases that doesn't always happen.

 

The fix:

 

1) Truncate your administrators, action_recorder and sessions database tables using PHPMYADMIN in your hosting account.

2) Delete the .htaccess and .htpasswd_oscommerce files from the /admin directory on your server using your FTP client.

3) Upload a NEW copy of the two files to the /admin directory

4) Clear the cookies and temp files from your browser (Firefox, IE, Chrome, etc)

5) Direct your browser to your admin area (ie. www.yourdomain.com/admin/) where you will notice it tells you that there are NO administrators created and you will need to create one, so do that. Create a new username and password. The screen will refresh. Now, using your NEW username and password, log into the admin area.

6) Once you are logged in, click on administrators on the left column and you will see the warning saying the site is not secured with .htaccess protection. Select the new log in name and click to enable it. It may ask you to confirm the password....MAKE IT THE SAME PASSWORD YOU USED TO CREATE THE NEW ACCOUNT. If your browser asks you if you want to have the browser save the password and your computer is secure and only used by you, then click yes.

 

 

You are done !

 

 

Chris

 

Thanks! I performed everything but the 2 in bold since I am not sure how to do #2 and what you mean by #3. Can you explain that in detail? Thanks!

Link to comment
Share on other sites

Now I am just having problems with #6....I am on the admin tab where it shows the warnings....I don't see anything that says to enable the protection...I updated the password a few times and when I click the red dot that says "secured by password" it has me re-enter the username and password and then I click save and it still shows the warnings and red light for "secured by password"

Link to comment
Share on other sites

  • 6 months later...

@@WickedMoto

 

In the most recent version of osCommerce there is NEVER any reason to set a password through your cpanel. So, lets stop that.

 

The other thing you have to realized is that if you set .htaccess password protection from your osCommerce admin area, it will write to two files in your /admin directory. .htaccess and .htpasswd_oscommerce it will ALSO write the password to your database and it will encrypt it.

 

If you change your admin area password you MUST also change the .htpasswd file. This is normally done at the same time but in some cases that doesn't always happen.

 

The fix:

 

1) Truncate your administrators, action_recorder and sessions database tables using PHPMYADMIN in your hosting account.

2) Delete the .htaccess and .htpasswd_oscommerce files from the /admin directory on your server using your FTP client.

3) Upload a NEW copy of the two files to the /admin directory

4) Clear the cookies and temp files from your browser (Firefox, IE, Chrome, etc)

5) Direct your browser to your admin area (ie. www.yourdomain.com/admin/) where you will notice it tells you that there are NO administrators created and you will need to create one, so do that. Create a new username and password. The screen will refresh. Now, using your NEW username and password, log into the admin area.

6) Once you are logged in, click on administrators on the left column and you will see the warning saying the site is not secured with .htaccess protection. Select the new log in name and click to enable it. It may ask you to confirm the password....MAKE IT THE SAME PASSWORD YOU USED TO CREATE THE NEW ACCOUNT. If your browser asks you if you want to have the browser save the password and your computer is secure and only used by you, then click yes.

 

 

Chris

 

After some time not loggin in I suddenly found that all our admin logins were rejected.

 

I did the above proceedure, except skipped #3 to leave out the htaccess additional protection. I am able to set the new admin in #5, but when I try to login with the new login I get the same "Error: Invalid administrator login attempt". When I go into mySQL and look at the adminitrators table there is one record with a blank username and an encrypted password. Tried using a blank username and also editin the record to add the username, with no success.

Is there anything else I can try?

 

Thanks, Mayda

Link to comment
Share on other sites

@@maydaohio

 

If when you create a new administrator username and password and then click the 'Create Administrator' button, the new username and password is NOT saved to the database, then you have a coding issue. What version of osCommerce are you using ? Any updates done ? What version of PHP is your server using ? What version of mySQL is your server running ?

 

 

 

Chris

Link to comment
Share on other sites

Chris, I am running v.2.3.1 no updates. php 5, mySQL 5.0 on Linux shared hosting on Godaddy. I think I found the root of the problem. We had recently moved domains and had the wrong url defined as Catalog and Server in the admin/includes/config.php and /includes/config.php. That was causing the admin logins to fail and fail from setting the admin from scratch.

Thanks for your response.

Link to comment
Share on other sites

@WickedMoto

 

In the most recent version of osCommerce there is NEVER any reason to set a password through your cpanel. So, lets stop that.

 

The other thing you have to realized is that if you set .htaccess password protection from your osCommerce admin area, it will write to two files in your /admin directory. .htaccess and .htpasswd_oscommerce it will ALSO write the password to your database and it will encrypt it.

 

If you change your admin area password you MUST also change the .htpasswd file. This is normally done at the same time but in some cases that doesn't always happen.

 

The fix:

 

1) Truncate your administrators, action_recorder and sessions database tables using PHPMYADMIN in your hosting account.

2) Delete the .htaccess and .htpasswd_oscommerce files from the /admin directory on your server using your FTP client.

3) Upload a NEW copy of the two files to the /admin directory

4) Clear the cookies and temp files from your browser (Firefox, IE, Chrome, etc)

5) Direct your browser to your admin area (ie. www.yourdomain.com/admin/) where you will notice it tells you that there are NO administrators created and you will need to create one, so do that. Create a new username and password. The screen will refresh. Now, using your NEW username and password, log into the admin area.

6) Once you are logged in, click on administrators on the left column and you will see the warning saying the site is not secured with .htaccess protection. Select the new log in name and click to enable it. It may ask you to confirm the password....MAKE IT THE SAME PASSWORD YOU USED TO CREATE THE NEW ACCOUNT. If your browser asks you if you want to have the browser save the password and your computer is secure and only used by you, then click yes.

 

 

Chris

 

Hi! I understood everything, but what do you mean by --------1) Truncate your administrators, action_recorder ------ ?

 

Thank you!

Link to comment
Share on other sites

  • 5 months later...

ThiagoL - Truncate means to delete all the RECORDS in the Table, while keeping the Table (and its structure) intact. MyPHPAdmin has an Operations tab for each table, and you'll find this command there.

 

 

I have this same problem and need to recreate an admin account. I've tried everything this post describes and I have two issues:

1- I don't have an original .htpasswd_oscommerce file for version 2.2, where do I get one?

2- Assuming that file isn't my problem, when trying to go to catalog/admin, I get this message before ever getting a login prompt:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'myusername'@'localhost' (using password: YES) in /home/myusername/public_html/catalog/admin/includes/functions/database.php on line 19

Unable to connect to database server!

 

I think this is what's keeping me from getting to the part where it asks me to create a new admin account. Why is it breaking so early; what do I need to change? Thanks!

Link to comment
Share on other sites

  • 1 month later...

Hi all,

I'm working on an osc 2.2rc2a site. Yes I know an upgrade is in process to 2.3, so please don't tell me I should do that first!

 

First off, I'm switching from a host that uses php 5.2 and need to get it ready for php 5.3. So I've done all those fixes but can't get into the admin panel of my local virtual machine that I'm using for dev purposes. So, I obviously changed my config.php files to use the local settings. Catalog and admin load, but can't get past the login screen on admin. I deleted my users from the administrators table. Created a new administrator, which then shows in the table. But the login credentials do not work. Please help, I have read page after page on this forum and have had no luck!

 

Ideally, I want to use the local/configure.php for dev purposes but those settings are not working either. Thanks in advance!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...