Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Database import problem


mtglick

Recommended Posts

Hi, all--

 

I'm cloning an existing installation on a new subdomain of the same server, and I've hit a wall. I need to run two parallel installations of the same store, with different products. The skin has some custom coding so I can't just go in a new direction--these need to be identical stores.

 

I'm running the original on a subdomain, and that works fine. I created a new subdomain, and copied all of the relevant files over, but the new install was still looking at the original database, so I needed to create a new database to point the new installation to.

 

Through myphpadmin, I exported the original database, and tried to import it as a copy, but since the import had the same name as the existing original, I couldn't import it (which made sense once I thought about it).

 

So I changed the name of the existing database to the name of the one I need for the new installation, and then imported the original database back in. The database is there, the data is correct, and it's named correctly, but the existing site is giving me a 1046 error. Nothing changed on the original site code (at least, I didn't change anything), and the database name matches the value in the includes/config file.

 

What am I doing wrong?

 

Thanks,

 

Matt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...