Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Customer cant log in when have products in basket


addeaz

Recommended Posts

Hi!

Please help regarding www.StylingAgenten.se, I really need it :sweating:

 

I recently detected an error after some customer complaints. When a customer put products in the basket and try to log in after the products are in the basket, they can't log in. They are staying at the login.php site, with no error displayed. When a customer login before they put products in the basket, they can log in.

 

There are not any problems if they create a new account though.

 

If I onced had products in the basket and try log in, and get this fault, then I cat log in even if I erase the products in the basket, I must reset the cache/cookies for make it able to login again without any products in the basket.

 

What do you think may be the problem?

 

Best Regards

Andreas

Link to comment
Share on other sites

Make a copy of login.php and edit this:

catalog/login.php: <?php echo tep_draw_form('login', tep_href_link(FILENAME_LOGIN, 'action=process', 'SSL'), 'post', '', true); ?>

 

I hope it works for you.

 

Hi,

Thank you for your help. I did that change and I still experienced the same problem (I did empty the cache too before trying.)

 

Any other idea?:)

 

I will go through if I did any changes the couple of days that maked this started (Im not sure when this problem started), one thing I did for a couple of days ago was to clear the sessions in database using the code below, but that can't create this problem?

 

DROP TABLE IF EXISTS sessions;
CREATE TABLE sessions (
 sesskey varchar(32) NOT NULL,
 expiry int(11) unsigned NOT NULL,
 value text NOT NULL,
 PRIMARY KEY (sesskey)
);

Link to comment
Share on other sites

Hi!

I solved the problem, it was the longradius social login addon that disturbed the login, when I erased this

 


require(DIR_WS_BOXES . 'sociallogin.php');

 

from column_left.php it did work again. It's pity, because otherwise that is a good addon. Maybe anyone have an odea why that disturb the login?

 

Best Regards

Andreas

Link to comment
Share on other sites

Hi Andreas - We have released the new version of Social Login yesterday with lots of great enhancements and also had a fix for this issue. Please install the new version-1.5 of Social Login and it should resolve this issue: http://addons.oscommerce.com/info/8306.

 

Let us know if you are still experiencing this issue and need further assistance, you can contact us at support.LoginRadius.com.

 

 

LoginRadius Team

Link to comment
Share on other sites

Hi!

I solved the problem, it was the longradius social login addon that disturbed the login, when I erased this

 


require(DIR_WS_BOXES . 'sociallogin.php');

 

from column_left.php it did work again. It's pity, because otherwise that is a good addon. Maybe anyone have an odea why that disturb the login?

 

Best Regards

Andreas

 

This is what happens when someone releases an addon and for some reason do not seem to test it. Personally i would steer clear of any addon without a good support forum.

REMEMBER BACKUP, BACKUP AND BACKUP

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...