Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

All links to products "not found", category hierarchy not working


suzgems1

Recommended Posts

Hello all -

 

Thanks in advance for your support here!

 

www.GouletDesigns.com

 

I recently went to my site and when clicking on the products links to see a detailed version of it, the page leads to "product not found".

 

Next, if I click on the products categories to see for instance, "Bracelets" or "Necklaces" it doesn't lead to a page listing all the products as I had them originally categorized. It simply goes to a new home page, with a random selection featured.

 

Can someone tell me what's going on? This is new and I don't know what to look for to fix it. I am pretty good with fixing these things on my own, if I have the right help.

 

Thank you!

 

Suzanne

 

www.GouletDesigns.com

Link to comment
Share on other sites

Looks like I suddenly have the same problem. Happened on all my vs 2.2ms2 sites. Thought it to be a Register Global issue, but Hosting company swears no changes were made. www.CoffeyFit.com is one of the sites down. No products can be seen on site or in admin panel.

any help is greatly appreciated!

caryl

Link to comment
Share on other sites

I am willing to bet you are hosting with Godaddy? I was away for a few days and came back to find three of my sites, all release 2.2, two on one server and another on a completely independent server, all broken. Categories don't work, info pages are lost, the admin is completely inaccessible.

 

I sure wish I had hosted someplace else way back when! I will look at this link and register globals issue today. The thing is, two of my sites have been patched so they don't use register globals anymore, while the third is still requiring globals on.

Link to comment
Share on other sites

  • 2 weeks later...

What url rewrite addon do you have installed?

 

Sorry I haven't been back here to check on answers... I was waiting for emails to come to let me know someone had answered and I didn't get any.

 

To answer your question in this post MultiMixer, I don't know what you're talking about! I don't think I have any rewrite addon at all. But it seems that this problem also showed up for other GoDaddy users, and I'm not sure what I'm supposed to do to address it. Thanks.

Link to comment
Share on other sites

I am willing to bet you are hosting with Godaddy? I was away for a few days and came back to find three of my sites, all release 2.2, two on one server and another on a completely independent server, all broken. Categories don't work, info pages are lost, the admin is completely inaccessible.

 

I sure wish I had hosted someplace else way back when! I will look at this link and register globals issue today. The thing is, two of my sites have been patched so they don't use register globals anymore, while the third is still requiring globals on.

 

Hello Drew - What do you mean "Register Globals"?

Do we know if the link above addresses the problem with people who have hosting with GoDaddy?

Link to comment
Share on other sites

  • 1 month later...

Just so you folks know you're not alone...

 

I too had an osC 2.2 site running on Godaddy that "broke" as described in August, 2012. I dug around and did a little patching but it didn't fix it. I contacted Godaddy who said they made some corrections on their end and that my site was now operating correctly on their end (they could pull up products and such) but I saw no difference from multiple machines?, multiple browswers, cleared my cache and all that.

 

My solution which probably isn't all that appealing was to start from scratch with a new up to date installation.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...