Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

upgrade to php 5.4.0 created problem


anandchawla

Recommended Posts

Dear guys

 

one month back my server upgraded php 5.4.0 sorted out all the issues only problem is that in checkout_confirmation page i am not getting Delivery address section, shipping method section , gift wrap section..they seem to be hidden,

the page starts with products..

 

this is causing me problem, i guess something to do with register globals off...can anyone advise how do i sort this problem

its a month now...and i m stuck in this

 

any upgrade guide on this....

mywebsite is www.plushplaza.com

pls help me out on this

 

Anand

Link to comment
Share on other sites

@@anandchawla

 

There are over 3200 known bugs with Php 5.4, your hosting provider prematurely updated their servers. I suggest you ask them to roll back to Php 5.3 until the bug are sorted out.

 

 

 

Chris

Link to comment
Share on other sites

What osC version are you running? Even PHP 5.3, which is pretty stable, will give you lots of problems with osC 2.2 levels. Did your host jump all the way from PHP 4 to 5.4? As Chris said, that was a jump too far. 5.4 is far too bleeding edge to be trying to run a production site. However, even at 5.3 you may have a lot of updating to do.

Link to comment
Share on other sites

osc 2.2, everything seems to work fine, only thing is i guess the values of delivery and shipping address are not passed, the rest all bugs looks clear

has anyone had same problem, pls help me on this if possible

Link to comment
Share on other sites

@@anandchawla

 

v2.2 is NOT compatible with PHP above 5.2. In fact, v2.3.1 is not even compatible with PHP 5.4. There is no support for PHP 5.4, it should not even be used at this point.

 

 

Chris

Link to comment
Share on other sites

There are many sub-versions of 2.2 (MS2, RC1, RC2, RC2a), each with different levels of PHP 5 compatibility. None will work with PHP 5.3 or above. Either think about upgrading to osC 2.3.1, which is PHP 5.3 friendly, or be prepared to do a lot of editing to whip your site into shape for PHP 5.3. In any case, you must roll back to something earlier than PHP 5.4.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...