Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Click to Enlarge problem


JOM

Recommended Posts

Hello,

 

(OSC v2.3.1)

I am having a problem with the link "click to enlarge" under the products picture. The problem is that is showing a text "undefined" instead "click to enlarge". It works fine when I click either the link or the picture. How do I change the text?

 

The only changes I have made so far is added the modules "easy populate" and "accordion categories menu"

 

Any help is appreciated.

Thanks

Link to comment
Share on other sites

/home/your domain/public_html/catalog//includes/languages/english/product_info.php

 

It seems to be there anyhow, hopefully it doesn't need changing somewhere lese too!

Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Link to comment
Share on other sites

Thanks for the reply

 

I see this line of code at catalog//includes/languages/english/product_info.php

define('TEXT_CLICK_TO_ENLARGE', 'Click to enlarge');

 

The image still have the text "undefined" underneath.

 

I used a similar topic to display "click to enlarge" on mouseover. It works

 

I've been changing catalog/product_info back and forth and I can not figure it out.

Could it be some other file I need to look into it?

Link to comment
Share on other sites

Maybe some help here

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Thank you, It works,

 

Now, the text is not centered in the image. It's left alinged. Do you know how to fix this

 

My code:

$pi_entry .= '" target="_blank" rel="fancybox" >' . tep_image(DIR_WS_IMAGES . $pi['image']," Click to enlarge" ,null, null, ' itemprop="image"'). '</a>';

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...