Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

USPS shipping module install


Guest

Recommended Posts

I just started trying to configure my site today and when I installed the USPS shipping module, I get the following message:

 

"You will need to have registered an account with USPS at http://www.uspsprioritymail.com/et_regcert.html'>http://www.uspsprioritymail.com/et_regcert.html to use this module"

 

Uhhhh, that site doesn't exist. http://www.uspsprioritymail.com/ doesn't even exist.

 

Is this a bad sign? Did my host install a bad/old version of this program?

 

Thanks in advance. I thought this would be pretty simple when I looked at it before it was installed, but it's really turning out to be pretty darn complicated.

Link to comment
Share on other sites

Thanks for the suggestion, Chris, but I actually did that and I get "An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner."

 

Can't figure out why that's happening. I figured it was because the user name, etc. wasn't from the right site.

Link to comment
Share on other sites

@cutegirliestuff

 

After you register with USPS, you have to send them an email asking to be switched to the "real" server.

  1. Create or login to your USPS.com account and sign up for a Web Tools User ID. You can find it in a box on the right hand side of the page at http://www.usps.com/webtools/ entitled "Access USPS Web Tools".
  2. Once you have received your email with your Web Tools User ID in it, contact USPS personally and request access to the production server by email ([email protected]) or phone (1-800-344-7779) because the requests sends out will not work at all in testing or production mode if USPS does not grant you access personally. Tell them that you are using OSCommerce which has been tested with their systems already.

Link to comment
Share on other sites

Thank you! I registered for that account, called in and got all switched over to the production server, put my account info in and I'm still getting the error.

 

Any other ideas?

Link to comment
Share on other sites

  • 3 weeks later...

I just installed this 2 weeks ago and didn't have any issues with the install or getting it working. However I am disappointed that after the install, the only USPS method of shipping that comes up on checkout is 'Library Mail'. There isn't any method of selecting shipping options to have available (Priority, Express, etc) in the module, as with Fedex for example. If anyone has anything better to use with a 2.3 site I'd appreciate it!

 

Thank you! I registered for that account, called in and got all switched over to the production server, put my account info in and I'm still getting the error.

 

Any other ideas?

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...