Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HELP cannot log in to admin panel


sunnydt

Recommended Posts

I dont know why this is happening all of the sudden. I havent done anything. When I go to my admin page to log in, it gives me a 403 forbidden error. The permissions were set to 744 so I changed them to 755 and now when I go there, it says "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete." All of my files in my admin folder are set to 644 and all folders in the admin folder are set to 755.

Link to comment
Share on other sites

@@sunnydt

 

Do you / Did you have an SSL installed that has since expired ? Has your domain name server been changed ? Has your IP address been changed ?

 

 

 

 

Chris

Link to comment
Share on other sites

I dont have the original. The backup I have is from last month when everything was working fine but I did not check to see if the admin was working or not so when I saw this was not working I did a restore hoping that would work and it didnt. It is still the same. I looked at my config files and all the info looks correct.

 

If my main directory is my catalog and I dont have a catalog folder, should this look like this?

define('DIR_WS_CATALOG', '/');

Link to comment
Share on other sites

I would guess a bad .htaccess rule as there is a failed redirect.

 

Try replacing your admin .htaccess with a new one that only contains the basic necessities

Link to comment
Share on other sites

Hi,

 

Typical install top level configure.php

 

<?php

define('HTTP_SERVER', 'http://www.********.com');

define('HTTP_CATALOG_SERVER', 'http://www.***********.com');

define('HTTPS_CATALOG_SERVER', 'http://www.**********.com');

define('ENABLE_SSL_CATALOG', 'false');

define('DIR_FS_DOCUMENT_ROOT', '/home/**********/public_html/');

define('DIR_WS_ADMIN', '/**********/');

define('DIR_FS_ADMIN', '/home/********/public_html/*********/');

define('DIR_WS_CATALOG', '/');

define('DIR_FS_CATALOG', '/home/*********/public_html/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', '***********');

define('DB_SERVER_PASSWORD', '**********');

define('DB_DATABASE', '********');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

To improve is to change; to be perfect is to change often.

 

Link to comment
Share on other sites

This is what my htaccess file looks like right now. What should it say?

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

# SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive ssl-unclean-shutdown \

# downgrade-1.0 force-response-1.0

# </IfDefine>

#</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

 

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

#php_value session.use_trans_sid 0

#php_value register_globals 1

Link to comment
Share on other sites

yes I go to the login.php page and it is saying the same thing.

The page isn't redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...