Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problems updating pages


bbel121

Recommended Posts

Hi,

 

I had an older version of osCommerce and just did a new install buying the osCommerce 2.2 rc2a verson from osommerce-packages.com. Boy what a mistake getting something from them. But anyway, I have a bigger problem I hope someone can help me with.

 

I have a few pages on my site that have links on them to other articles or products. Here is an example of one of those page. Now if you click any link on the page it returns a page not found. But if you append a backslash to the end of the URL it will work.

http://www.certificationkits.com/ccna-certification-study-topics/

 

The problem is when I imported this page into the new site osCommerce strips off the trailing backslash from any links for some reason. It did not do this in the previous version of osCommerce I had. No matter how I edit the page(with the WYSWYG editor, direct HTML edit) to add the trailing backslash to the link, when I click update, osCommerce strips the trailing backslashes off ALL the links on the page. So now I have a page of 90 broken links.

 

As mentioned, I tried the WYSWYG editor, I tried clicking to edit the HTML direct, I tried copying the HTML from notepad into osCommerce and it is fine until I hit update and then it strips it off.

 

I have tried IE, Firefox, Chrome and each from 2 different computers to make sure it was not a host or browser issue.

 

Do you know of any other thing I can try? I may have to revert back to my old site if I can't figure this out.

 

I got to figure out a way to fix these broken pages.

 

Thanks,

Bob

Link to comment
Share on other sites

Two other peices of information:

1) It will let me update other items on the page like text.

2) If I break the link, then recreate the link and save the page. That one link is ok.

 

But as soon as you go back to edit anything on the page (or as soon as you open it in the Article Editor), you lose the trailing backslash on all of the URL links.

 

Even if you don't save the page, it is lost. But as long as I do not open it again, it is fine.

 

Please help!!!!

Link to comment
Share on other sites

Hi,

 

Last piece of info where I have sort of a work-around. So if anyone else sees this or has come across it before, any additional info is appreciated. No matter what browser I use(IE8, FF, Chrome), I can't use the WYSWYG or it will strip off the trailing backslashes but update everything else ok. Firefox and Chrome using the HTML editor does the same. But if I use IE8(IE6 does not work) for some reason it does not seem to automatically invoke the WYSWYG editor and if I stay in plain HTML without launching the HTML editor, the page will save properly.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...