Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Errors after installation


grizhdazabar

Recommended Posts

Hello all,

 

I wish to ask for your help regarding the installation of my store.

I've followed the instructions but at the end these are the errors resulting and at the end the website won't work but displays the following:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in/home/content/21/8973321/html/catalog/admin/includes/functions/database.php on line 19

Unable to connect to database server!

 

 

 

These are the warnings resulting after trying to install the oscomm.

 

Finished!

 

 

Warning: fopen(/home/content/21/8973321/html/catalog/ /includes/configure.php) [function.fopen]: failed to open stream: No such file or directory in/home/content/21/8973321/html/catalog/install/templates/pages/install_4.php on line 116

 

Warning: fputs(): supplied argument is not a valid stream resource in /home/content/21/8973321/html/catalog/install/templates/pages/install_4.phpon line 117

 

Warning: fclose(): supplied argument is not a valid stream resource in/home/content/21/8973321/html/catalog/install/templates/pages/install_4.php on line 118

 

Warning: fopen(/home/content/21/8973321/html/catalog/ /admin/includes/configure.php) [function.fopen]: failed to open stream: No such file or directory in/home/content/21/8973321/html/catalog/install/templates/pages/install_4.php on line 152

 

Warning: fputs(): supplied argument is not a valid stream resource in /home/content/21/8973321/html/catalog/install/templates/pages/install_4.phpon line 153

 

Warning: fclose(): supplied argument is not a valid stream resource in/home/content/21/8973321/html/catalog/install/templates/pages/install_4.php on line 154

The installation and configuration was successful!

I'd appreciate very much all your comments and thank you in advance.

best,

Ardita

Link to comment
Share on other sites

/home/content/21/8973321/html/catalog/ /includes/configure.php is not a valid file path. Any idea how you ended up with the extra / and space (blank) in there? Did you define the store base path as '/home/content/21/8973321/html/catalog/ ' when it should be '/home/content/21/8973321/html/catalog/' or even '/home/content/21/8973321/html/catalog'?

Link to comment
Share on other sites

I don't know. I just followed instruction.

Anyway, at the end i did it and i have it installed, just that at the admin panel and on the website no photos or graphics are showing!!

 

eno-al.com/catalog

 

thank you very much.

 

ps. no I haven't touched any of the codes because i barely understand them.

Link to comment
Share on other sites

Some of the images show the classic signs of being FTP'd to the server in "TEXT" or "ASCII" mode.

 

Change the settings on your FTP program to use "BINARY" mode for images andf FTP them to the server again.

 

NOT the text (.php) files, JUST THE IMAGES.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

So you got through the installation and those error messages like Warning... are all gone? The only problem now is that images don't show? I agree with @@germ that at some point you probably transferred your files incorrectly. By any chance did you use FileZilla and bulk transferred the files while letting FileZilla choose the mode (automatic)?. That will do it. FileZilla is nice, but you really have to watch it when you let it choose file transfer modes!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...