Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can't Login - Took over site when starting new job


forbes

Recommended Posts

Hi all,

I am having an issue with loggin in to the oscommerce admin cpanel. I have truncated the administrators table, created a new username and password through the browser and I am still unable to login to the admin cpanel. I am not sure which version we are running on the site. Does anybody have any ideas? I can provide more information if needed. I have also tried adding a user manually and setting the password to MD5. I have also tried using a third party MD5 password generator with no luck.

Thanks,

Forbes

Link to comment
Share on other sites

You need to remove the .htacess and .htpasswd from the admin directory.

You need to truncate the administrators table.

 

You need to get a new version of the htaccess and htpasswd file from a clean 2.3.1

 

You need to go to the admin login page and insert a new admin user.

You need to login

You need to go to the administrators page

You may need to set permission on the ht* files.

 

You now need to update the user to protect it with htacess/htpasswd.

You need to use the same username and password as you logged in with.

Link to comment
Share on other sites

i idid the first two steps and got a clean install .htaccess and .htpasswd_oscommerce from 2.3.1. I followed the create admin and login steps and it is still refusing me access. Do I wait to copy over the htaccess files until after creating an admin or before?

Link to comment
Share on other sites

@@forbes

 

Copy NEW /admin/.htaccess and /admin/.htpasswd_oscommerce files from the original download to the /admin/ directory overwriting the current files. Then, log into the admin area (assuming you know the current username and password, if you do not....you will have to truncate the administrators and action_recorder tables using PHPMYADMIN). Once you are in the admin area, click administrators under the configuration menu and enable .htaccess protection again.

 

 

 

Chris

Link to comment
Share on other sites

  • 2 weeks later...

I'm getting the exact same problem and no way to fix it... driving me crazy! i am on version 2.3.1 osc

 

before I could, now I can't, I have truncated the action recorder, the administrator, created with phpMyadmin new login user and password, and no luck so far... why does this happen? it should let you in if you created it on the phpMyAdmin side....

 

any other ideas?

Link to comment
Share on other sites

Ok I got it fixed, go here and follow this youtube video:

 

just go to the phpmyadmin, truncate the administrators table, then don't created there, go to your admin url (site/admin), there you will see the message that no admin exist, and it asks you to define it there, go ahead, write in the admin and password, after that log in with both of the new created user and password.

 

I think the problem, when you create the first one, it has to be coded like the oscommerce does, ... anyway, this has worked for me!

 

:thumbsup:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...