Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.


Skslsbdk

Recommended Posts

Hello computer wiz peeps,

 

Here is the problem.. under categories in the admin site for my shop, some folders were accidently deleted, I went into the tools section and did a restore but I hadn't backed up for a while (lessen learnt, regularly backup!) anyways thought if I call my hosting provider they will have a more recent backup, they did, restored it and now my shop isn't working at all since they did a restore comes up with these errors:

 

Warning: require(includes/languages/.php) [function.require]: failed to open stream: No such file or directory in /smhhome/b-web/b6/ba/fruitfulvine.com.au/public/www/shop/admin/includes/application_top.php on line 130

 

Warning: require(includes/languages/.php) [function.require]: failed to open stream: No such file or directory in /smhhome/b-web/b6/ba/fruitfulvine.com.au/public/www/shop/admin/includes/application_top.php on line 130

 

Fatal error: require() [function.require]: Failed opening required 'includes/languages/.php' (include_path='.:/smhhome/chroot_bind/php/php5/usr/local/lib/php/') in /smhhome/b-web/b6/ba/fruitfulvine.com.au/public/www/shop/admin/includes/application_top.php on line 130

 

They told me the files were missing, but when I checked in FTP they were there?!

 

I don't know much about all this as I just maintain and update new stock that needs to go onto the shop but cant now because its completely down!!

 

Anyone have any ideas, someone told me it might be something to do with the permissions but want to check with all you guys!

 

Any help would be very much appreciated!

 

Thanks, Rob.

Link to comment
Share on other sites

sounds like you might be using an older osc version and need to update to the latest....

Link to comment
Share on other sites

Hello computer wiz peeps,

 

Here is the problem.. under categories in the admin site for my shop, some folders were accidently deleted, I went into the tools section and did a restore but I hadn't backed up for a while (lessen learnt, regularly backup!) anyways thought if I call my hosting provider they will have a more recent backup, they did, restored it and now my shop isn't working at all since they did a restore comes up with these errors:

 

Warning: require(includes/languages/.php) [function.require]: failed to open stream: No such file or directory in /smhhome/b-web/b6/ba/fruitfulvine.com.au/public/www/shop/admin/includes/application_top.php on line 130

 

Anyone have any ideas, someone told me it might be something to do with the permissions but want to check with all you guys!

That can be caused by many things. Without knowing more details I can only guess but try this to start. Login to your admin and then change the url to ....com/admin/index.php?language=en (fill in the missing domain name, of course). Does the page load?

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

How do I do this.. and pretend your talking to a 5 year old because it's kind of all new to me!

 

You can either use your FTP client or your Hosting Control Panels file manager to check the file permissions. Ensure that directories are 755 (705 is better) and files are 644 (604 is better). With the two configure.php files set to 444

 

 

 

Chris

Link to comment
Share on other sites

@@Jack.. tried what you suggested, still loads the same what more do you want to know?!

Then it sounds like the files are missing. When you tried to do a restore, that was a database restore, unless you have some contribution installed that does a file restore. When you asked your host to restore, did they do a database resotre or was the whole account restored? If they are saying the files are missing, without actually looking, shame on them. But if they looked and can't find the files, then that would be the problem.

 

Is your domain name fruitfulvine.com.au? When I try that it redirects to a different url. The reason I ask is that I am wondering if the shop side loads correctly. That may help isolate the problem.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

You can either use your FTP client or your Hosting Control Panels file manager to check the file permissions. Ensure that directories are 755 (705 is better) and files are 644 (604 is better). With the two configure.php files set to 444

 

 

 

Chris

 

Ok Chris, I can't do this till I get into the office in a a couple of hours. Thanks though.. will check it out asap!

Link to comment
Share on other sites

Then it sounds like the files are missing. When you tried to do a restore, that was a database restore, unless you have some contribution installed that does a file restore. When you asked your host to restore, did they do a database resotre or was the whole account restored? If they are saying the files are missing, without actually looking, shame on them. But if they looked and can't find the files, then that would be the problem.

 

Is your domain name fruitfulvine.com.au? When I try that it redirects to a different url. The reason I ask is that I am wondering if the shop side loads correctly. That may help isolate the problem.

 

I checked on FTP yesterday, the files were there, might be in the wrong place have no idea but its not working!

 

Yes it gets redirected to fruitfulvine.org, the url for the shop is https://secure.fruitfulvine.com.au/shop/

 

The hosting company did a database restore first, thats when it crashed, they then did a whole restore to try and rectify the problem and it did nothing, I'm guessing they didn't look because I can see the files.. assuming I'm looking at the right files!

Link to comment
Share on other sites

I checked on FTP yesterday, the files were there, might be in the wrong place have no idea but its not working!

 

Yes it gets redirected to fruitfulvine.org, the url for the shop is https://secure.fruitfulvine.com.au/shop/

 

The hosting company did a database restore first, thats when it crashed, they then did a whole restore to try and rectify the problem and it did nothing, I'm guessing they didn't look because I can see the files.. assuming I'm looking at the right files!

OK, so the shop side is down too. Try creating a file named test.php with the following contents
<?php
include('includes/languages/english/privacy.php');
echo TEXT_INFORMATION;

Then go this page: secure.fruitfulvine.com.au/shop/test.php

If the load fails, then the file is missing. Otherwise it should display your privacy page information.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

OK, so the shop side is down too. Try creating a file named test.php with the following contents

&--#60;?php
include('includes/languages/english/privacy.php');
echo TEXT_INFORMATION;

Then go this page: secure.fruitfulvine.com.au/shop/test.php

If the load fails, then the file is missing. Otherwise it should display your privacy page information.

 

Ok, stupid question, I'd create that using dreamweaver? yeah

 

When I went through FTP yesterday I looked both in ...shop/admin/includes and shop/includes, both had application_top.php on the list?!

 

Anyways will give it a bash when I can and let you know! Thanks Jack!

 

ps. Don't know if this means anything but typed in https://secure.fruitfulvine.com.au/shop/includes/languages/english/privacy.php = blank screen.

Link to comment
Share on other sites

Most likely they have also upgraded your hostings php/mysql version and if you are running an old oscommerce version some functions will not work since they depend on functions which is depreciated in newer php/mysql versions.

 

If that is the case you need to upgrade your shop.

Link to comment
Share on other sites

Ok, stupid question, I'd create that using dreamweaver? yeah

 

 

ps. Don't know if this means anything but typed in https://secure.fruitfulvine.com.au/shop/includes/languages/english/privacy.php = blank screen.

You can create the file with any editor, even notepad. You shouldn't be able to access the file directly. The fact that you got a blank screen and not a warning indicates your shop is not secure. Of course, that is impossible to say at this point since we don't even know if all of the files are there,.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Ok, so called hosting company and had a go at them...

 

Shop is back up they said they lost files but did another restore and I don't know what they did exactly but anyways..

 

Shop and Admin panel are working.. sort of!!!

 

Firstly in shop.. It looks like most things are back.. except all the values (price) of the items are all $0, do I have to manually put these figures back in?

 

Secondly in admin.. this is the error I get when clicking on customers:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select c.customers_id, c.customers_lastname, c.customers_firstname, c.customers_email_address, a.entry_country_id from customers c left join address_book a on c.customers_id = a.customers_id and c.customers_default_address_id = a.address_book_id order by c.customers_lastname, c.customers_firstname limit -20, 20

 

Similar errors come up when I click on locations and localization...

 

Any suggestions.

 

Want to fix this then upgrade to a newer version of oscommerce, we are running a very old version, need to know how to do this too but priority is above error.

 

Thanks guys!

Link to comment
Share on other sites

Those errors are because you are running an old oscommerce version... you can look through the forum for fixes for just those errors or you can bite the bullet and upgrade to a newer version.

Link to comment
Share on other sites

Those errors are because you are running an old oscommerce version... you can look through the forum for fixes for just those errors or you can bite the bullet and upgrade to a newer version.

 

If I bite the bullet will I lose any info like customers that have signed up, orders sold etc? Or will it all be intact? If so I'll upgrade, just need to know how! I'm no programmer so if its just a matter of putting in a file in FTP or something I can do that.. but somehow I don't think its going to be that easy! lol

Link to comment
Share on other sites

You can download oscommerce 2.31 and inside you will find an upgrade document with detailed instructions.

 

But you will probably find it much easier to start over with a new 2.3.1 shop. You can eighter modify your current db so that it can run 2.3.1 or import in customers/orders/products/categories from your old db into a new 2.3.1 db.

Link to comment
Share on other sites

I am in the process of getting a web developer in,

 

Appreciate your time guys, I personally just don't have the time! This way it can be fixed quickly so the shop can be up and running again like normal, with all the updates etc. with only a small fee, HOPEFULLY! Think this is the best option,

 

Apologies to those who will look at this thread, have the same issues wanting answers and not really get anywhere with it!

 

Rob

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...